OMG!! This Software seems so broken!! Someone please help.

#1
I have a Toshiba laptop that has Windows Vista. I recently decided to try out Linux again. I installed Ubuntu to a USB hard drive. I wasn't touching the Vista partition at all. Vista was completely unaware of Ubuntu. I used the BIOS setup to boot from the USB drive. There Grub had an entry for Vista. Everything was cool. The only drawback being that the BIOS would forget about the USB drive if was powered down or disconnected at any boot. But it would boot Vista from the internal drive fine. I just want to set up a bootloader menu in Vista that would persist even after disconnecting the drive. I assumed this should be doable and if I stupidly chose the Ubuntu distro for booting when it was unavailable I would get a "Missing operator system" message at worst.
I downloaded and installed EasyBCD 1.7.2 and ran it. I added an entry for Ubuntu pointing it to the USB drive partition. I restart. I get the new bootloader menu fine. I can choose Ubuntu and it boots fine. I restart and boot into Vista fine.
But when I try to run EasyBCD now I get "Valid BCD Registry not detected" I go trough a couple of dialogs that ask me to point to the boot drive and Vista partition but fails and takes me through the same loop of dialogs endlessly.
I searched for "Valid BCD Registry not detected" in the forums and tried someones advice to use a 2.0 beta EasyBCD. I could get 1.7.2 to run even if I uninstalled/reinstalled. Running bcdedit /enum resulted in something like No store "File not found" (note it did NOT say Access Denied).
The View Settings Section of EasyBCD was grayed out. And the edit window said something like "no entries". Keep in mind I did have a bootloader menu - with entries for windows and Ubuntu. I used the Bootloader Setup section to "Write MBR". I noticed the activity light on the _USB_ lit. And when I reboot - the BIOS is still pointing to the USB drive - I get Missing operator system.

Can anyone figure out what is going on?

Here's the current output of bcdedit /enum:
Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {globalsettings}
default {current}
resumeobject {b17b4ad3-c1dc-11db-a246-001636631e1c}
displayorder {current}
{a24fe4cb-52bf-11df-9119-001636fc36db}
toolsdisplayorder {572bcd56-ffa7-11d9-aae0-0007e994107d}
{memdiag}
timeout 30
resume No
customactions 0x1000000720001
0x54000001
custom:54000001 {572bcd56-ffa7-11d9-aae0-0007e994107d}

Windows Boot Loader
-------------------
identifier {current}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
locale en-US
inherit {bootloadersettings}
recoverysequence {572bcd56-ffa7-11d9-aae0-0007e994107d}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {b17b4ad3-c1dc-11db-a246-001636631e1c}
nx OptIn

Real-mode Boot Sector
---------------------
identifier {a24fe4cb-52bf-11df-9119-001636fc36db}
device partition=C:
path \NST\nst_grub.mbr
description Ubuntu

I have to clarify something. I think EasyBCD did work for the Ubuntu at all. I believe it resulted in what I get now. -
BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant BootPart
Loading new partition
Bootsector from C.H. Hochstӓtter
Cannot load from harddisk
Insert Systemdisk and press any key

However I could boot into Ubuntu by pointing the BIOS to the harddisk.
 
Last edited:
#2
Two things to consider ...

First, in my experience, GRUB automatically installs to the "first" drive it finds. So, even though you were booting from the USB, if GRUB thought your internal drive was "first", it installed itself there. Your last statement that booting from the hard drive launches Ubuntu tends to bear this out.

Second, I ran into the same inability to find the BCD store when I first installed EasyBCD -- but that is easily fixed by browsing to the partition containing the BCD and selecting that. After that, in my experience, EasyBCD remembers where the BCD is stored and opens that one.
 
#3
OK - first GRUB installed to the external USB drive which is not the first one found. The internal hard drive was untouched by the Ubuntu install or GRUB. I thought I made that clear.

Everything was working fine until I tried to use EasyBCD to make a Vista menu of boot options. GRUB doesn't enter into it at all.

Secondly I tried to point it to the partition where the store was. It said it could not find it there (on the C: or internal drive). As I said that just resulted in an infinite loop.
 

Terry60

Knows where his towel is.
Staff member
#4
If you sucessfully used EasyBCD to set up the dual-boot menu, and booting both OSs worked fine, why are you trying to run EasyBCD now? What do you want to do ?
EasyBCD looks for the BCD on the active partition of the boot drive.
You don't have a BCD on your USB drive, so it will only find the BCD if you have the HDD first in the boot sequence. You seem to be saying that you've left the USB as the boot drive, in which case grub is doing the booting, not Vista.(although rewriting the MBR might have screwed your grub MBR by replacing it with a MS Vista version on the USB drive)
If you use 2.0, it will offer you the chance to point it to a BCD as it starts if there isn't one on the "active" partition.
 
Last edited:
#5
I'm sorry - I thought I was pretty clear in my first post. Well I'll try again. I have not successfully set up anything with EasyBCD.

I set up Ubuntu on an external USB drive. That was the only successful part here. It was dual boot in the sense that when the USB drive was connected to the laptop I could go into the BIOS setup and say boot from the USB drive. Grub was there and I could choose Vista from there. This setup lasted as long as I only warm booted and kept the USB drive connected and powered up. Once it is disconnected or powered down or the computer is powered the BIOS setting is lost. The internal hard drive becomes the boot drive. There was no dual boot capabilty there - that's what I wanted EasyBCD for.

And that's where thing's royally screw up. Just ignore the dual boot issues for a minute. If I go to the Bootloader Setup section and I have a button that says "Write MBR" with a companion set of 2 radio buttons - one label "Install the Vista/ Windows 7 bootloader" and one labeled "Install the Windows XP bootloader", am I really being unreasonable in expecting that this is not going to do anything to the external drive? I don't think so.

In fact, I finally got this working. I first had to restore GRUB. When I did this and went back to Vista and ran EasyBCD it again complained it couldn't find the bcd store even though the menu of options had been displayed at boot. The View settings section controls were grayed out again. I powered down the USB drive and I then I could run EasyBCD without the error. I went to the Bootloader setup section again pressed the "Write MBR" button (for Vista). Now it works.

It seems clear to me that EasyBCD has big-time problems dealing with this particular use case.
 

Terry60

Knows where his towel is.
Staff member
#6
Sorry. I quote your OP

I downloaded and installed EasyBCD 1.7.2 and ran it. I added an entry for Ubuntu pointing it to the USB drive partition. I restart. I get the new bootloader menu fine. I can choose Ubuntu and it boots fine. I restart and boot into Vista fine.




 
#7
Yeah, I appended the fact that it actually didn't work. Things just starting going from bad to worse so badly I had forgot that It did not actually boot Ubuntu.
 

Terry60

Knows where his towel is.
Staff member
#8
The BCD is an "always open" sort of file and by MS design meant to be "one of a kind", even for multiple Windows installations.
EasyBCD 1.7 predates W7 and grub2, and even the grub1 syntax change to use of UID instead of hd(x,y).
Consequently it was designed to access the "only" BCD on the "active" boot drive and performs all its operations under those assumptions.

Some of us have unconventional boot setups, not envisioned by MS architecture.
W7, grub2 etc. came along, so CG wrote EasyBCD 2.0 which contains support for all the later software, USB drives, Virtual systems, multiple BCDs and so on, and has been restructured to keep safe "basic" functions and more dangerous "advanced" techniques separated

1.7 was never intended, designed or coded to handle being run on a system booted by a third-party manager, from a different HDD.
The Install /uninstall Vista bootloader function is designed to replace a Vista boot broken by a later XP install, or revert to an XP boot if abandoning Vista. In either case, due to the previously mentioned MS architecture, it will operate on the "active" partition.
 
#9
I hear some of what you say, but it doesn't explain to me why it would mess with my external hard drive when I ask it to write the MBR installing the Windows Vista / 7 or XP. It specifically is NOT the active partition. But it seems EasyBCD is just spraying mbr's to any connected hard drive like a fire hose.
 

Terry60

Knows where his towel is.
Staff member
#10
It's the boot drive in your BIOS. That's what you asked it to rewrite. It's not randomly selecting a location.
Use EasyBCD 2.0
EasyBCD 1 pre-dates all of your software. It was a simple app without all of the automatic features of 2.
It expected the user to understand the dual-boot process, and it simply did what the user instructed it to.
It had no clairvoyant features.