OpenELEC and Windows 7

edgar669

New Member
Hi,

I am trying to build a dual-boot with OpenELEC and Windows 7, both installed on one harddisk. I had a lot of trouble installing OpenELEC on the harddisk. After all it is running on a fat32 partition (/dev/sda1) with an additional partition for the storage (/dev/sda2). The /dev/sda1 is a fat32 partition and to boot OpenELEC I have used syslinux. When this partition is set active OpenELEC boots. But I do not get it running by EasyBCD. I have tried the LILO-Option and also NeoGRUB. Additionally i Have tried the EasyBCD Beta 2.1 with Syslinux-option. Unfortunately all without success. Any idea?
Partitions:
/dev/sda1: primary part., fat32, OpenELEC, syslinux
/dev/sda2: primary part., ext3, Storage for OpenELEC, no system
/dev/sda3: primary part., NTFS, Windows 7, normally active

Messages when booting with
-LILO-Option: Boot Error
-Syslnux-Option: Boot Error
-NeoGrub: Try (hd0,0): fat32: No NEOGRUB

Thanks!
 

JustinW

Super Moderator
Staff member
The makeactive command may work with the entry to boot it in NeoGrub's configuration.
 

edgar669

New Member
Hi JustinW,

thank you for the reply! I also thought of this. But unfortunately without success:

...
rootnoverify (hd0,0)
makeactive
chainloader +1
 

mqudsi

Mostly Harmless
Staff member
It looks like you installed syslinux to the mbr of that disk and not its partition?
 

mqudsi

Mostly Harmless
Staff member
The USB is probably the reason why it's not working.
 

mqudsi

Mostly Harmless
Staff member
You need to play around with your BIOS's USB settings. If you have something called legacy USB, make sure it is enabled.
 

mqudsi

Mostly Harmless
Staff member
That's good news. Did you have to do anything special to get it working?
 
Top