OpenGL Workstation GPU


Distinguished Member
So i will be getting my laptop tomorrow (when ill post the specs) but the laptop is a workstation and has a Nvidia Quadro FX 1600M.

Now i know from this wiki page ( OpenGL - Wikipedia, the free encyclopedia ) some of the games it can play, but does anyone on here know more games that support opengl?

Also people in my classes have been asking me (seeing as i know alot about our laptops we have yet to get, and i have only look at the hp page for the machine lol) are wondering if it is possible to get the directx (draw3d or something) on these machine?
It has DirectX, you should be able to game with it.... as far the performance goes though, I have no idea.
well i mis spoke, it has a 570m opengl card, but it seems to play audio surf and CSS perfectly, and dawn of war (i may i have misread)

But i get 95.99 FPS on CSS on top graphics with the rez @ 1680x1050 (16:10 ratio). so i think ill be fine lol for the most part, time to install COD4, Sup Com, and DoW:SS lol

Even if it would be OpenGL only, you have a decent list of games there. :smile:

I think today I should be getting my new PC :wtf: I can't wait!!! :lol::happy::lol:

i have been having issues with games, most recently CnC3 Tiberium wars. i just bought the game and ive already once reinstalled it.

it would seem there is an issue with my gfx card and Direct3D

No problems found.
DirectDraw test results: Failure at step 17 (SetDisplayMode to 640x480x16): HRESULT = 0x80004001 (Not implemented)
Direct3D 7 test results: Failure at step 39 (SetDisplayMode to 640x480x16): HRESULT = 0x80004001 (Not implemented)
Direct3D 8 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x88760827 (error code)
Direct3D 9 test results: Failure at step 6 (No hardware supported display modes found): HRESULT = 0x80004005 (Generic failure)

Those errors were generated in "dxdiag" when i tried testing DirectDraw and Direct3D.

when trying to run CnC3, the game crashes on launch (no fullscreen) and give me an error, with the top line saying something about "D3Derr" (i couldnt get a screencap, prt sc was being gay)

ive also been having some other problems,

could it be Crysis (that i installed last week)?

crysis runs well enough (and i get high settings on auto-set)

so idk, ive fully updated CnC3.
last time i downloaded and tried to install them it told me i had the wrong versions of something somewhere ill try it again now

same error about hardware as before:

and i did select the correct driver, quadro FX 570M

one of the problems may have been not selecting M quadre type chipset :wink:

i let nvidia scan for me and directed me to HP, downloaded drivers now


  • nverror.png
    91.3 KB · Views: 3
Last edited:
The game seems to run fine ^__^

ill try it again later today to make sure.

i tried to run CnC again, and it crashed, no error, just crash

and then my lit brother tried playing Gmod and it crashed again, and i was given this error code from windows

[URL=""]Error Message: STOP 0x000000EA THREAD_STUCK_IN_DEVICE_DRIVER (Q293078)[/URL]
my machine now passes all of the Directdraw and Direct3D (7, 8, and 9)'

Here is the error from CnC3

ill try another reinstall later right now i have laundry to do lol


  • Untitled.png
    18.5 KB · Views: 1
Last edited:
So i have reinstalled the correct driver from HP for my GFX card. Still crashing games. Ive uninstalled a lot of games and software, no luck there either (anything that would have installed a different version of DirectX, Crysis, farcry, UT3)

im uploading my DirectX diagnostics tools info in this post for you guys. i am getting upset, no one else in my class seems to be having these issues besides me :frowning:


  • DxDiag.txt
    51.3 KB · Views: 1
Hi Kahai.

Have you solved your direct3d problems?
I have same problems and would like to know if there is any solution..
Best regards