OpenSolaris grub


New Member
I had a multi-boot setup, with Vista and some Linux distros. Yesterday I installed OpenSolaris for a try, and when I attempted to open EasyBcd for reinstall Vista's bootloader as primary, I got the message window "Valid BCD Registry not Detected" "... let EasyBcd correct... etc". Then I click yes, but EasyBcd is unable to perform the reparation and don't loads (I tried with all drive letters).
I would like get rid of OpenSolaris grub :angry: and reinstall Vista's booloader. Can you help me please?
Thank you.

Mak 2.0

Staff member


New Member
I tried it by using the Vista dvd and with Easybcd but did'n work. In the case of Vista dvd nor operative systems are listed to repair, and in the case of Easybcd it don't loads as I explained in my post.

Mak 2.0

Staff member
Please read the page. There is more than just with the CD/DVD and EasyBCD listed in there.
I was considering going for OpenSolaris since I could never get Solaris 10 to run here seeing that was an open source release. You likely ran into the same problem as seen here with Mandriva 2006 where it has it's own form of dominant universal boot loader that overwrites the Vista mbr even when installed to a separate drive making that the default OS.

That however was fixed rather fast when simply booting up with the VIsta dvd to use the startup repair. But since that as well as the options in EasyBCD haven't worked another method is to rebuild the BCD as seen at


New Member
bootrec.exe /fixmbr
--> //ok
x:\boot\bootsect.exe /nt60 all /force
--> // The system cannot find the path specified

I can enter in all the os installed, BUT via the Solaris grub.
I have 2 different installations of Vista x64, an 3 of
Linux (Ubuntu, Mint and Mandriva) plus Solaris. Then the first think I see when
the computer starts is the Solaris grub, and from there I can go to
the Vista bootloader. And from the Vista bootloader I can enter
in all the other systems. Then I go to one of the Vista installations
and try to open Easybcd, but I get this message:
"EasyBCd has detected that your BCD boot data and MBR are either
not from the latest... bla, bla, bla...
If you'd like EasyBCD to correct these issues, press OK... bla, bla..."

Then I press "ok", and the second window appears:
"Unfortunately, EasyBCD could not automatically detect the drive letter
of your boot device... etc" "Please enter the letter of your boot drive
below... "

Then I chose the diferent letters listed there and the first screen
appears again >.<.

I tried too the steps of the Microsoft page suggested by Pc Eye
but I've got a similar result:
bcdedit /export C:\BCD_Backup
--> // The system cannot find the path specified

So, actually though I can access to all the os's is only via
Solaris grub --> Vista bootloader and I'm unable to delete Solaris grub
or manage the Vista bootloader at all.

Pd. Sorry if something is difficult to understand, but english
is not my native language.
Last edited:


New Member
When I open command prompt I see this:
then if I type
X:\Sources>x:\boot\bootsect.exe /nt60 all /force
is when I get the message of the wrong path.


Problem solved with Acronis Disk Director Suite. I delete de Solaris partition and then I was able to open EasyBCD, and fix mbr.
Last edited:
The OpenSolaris boot loader sounds familiar to that seen with Mandriva 2006 which saw two Vista entries one above the other with "C:\Windows" at the top in what looks like a header followed by Windows1 also Vista and then Windows2 for XP when that was on. Following a repair of the Vista mbr and setting the second XP drive as the default boot device Mandriva could still load the Vista/XP dual boot.

That was seen when adding Mandriva after the dual boot like you saw with OpenSolaris. You could run it if you are trying to multiboot across two not one single hard drive by unplugging the Vista drive first using the second for OS and Linux with the OS boot loader handling the distros. You then point NeoGrub at the OS loader as a single option followed by selecting OS or one of the distros after.

It's just an additional thought to add here if you are still interested in seeing OpenSolair run along with WIndows and Linux. EasyBCD was intended for Vista while being backward compatible with older versions. Unfortunately you let the OS loader replace the BCD there. At least you are back running now.
I don't belive I'll try Solaris again. I did'n find it too interesting; just a Linux like look, and a lot of problems and incompatibilities, not to mention it's egocentric grub :glare:.
Well that's sums it up for that OS then! :happy: I was thinking about trying that myself since I didn't get anywhere with Solaris 10 when downloaded some time back.

Presently I would to see Mandriva 2009 get installed and running but ran into an installation problem being looked for both 32bit and 64bit versions. Ubuntu 8.10 64bit is already running in the mix here.
You're welcome! kairozamorro

Yes ubuntu like a few other small distros that see live versions have grown considerably in popularity for being much easier to use with less and less use of Bash commands for manual configurations and simply seeing a distro installed. The newer releases for Fedora are also much easier to work with from what I understand over what was seen with earlier releases like Core 4.