OSX 86 and Windows 7 dual boot

I've looked through the threads and don't see my problem(s). I've had OSX 86 up and running (GigaByte motherboard) with Chameleon 2.0 for several months. Everything works. I have another machine (Asus motherboard) running Windows 7.

On the Windows machine I installed EasyBCD (1.7.xx - I'm not at home right now). I added an OS86 entry through EasyBCD. I then moved the Windows hard drive to the OSX machine. I changed the BIOS so that the windows drive was first in boot order. When I boot the machine the Windows drive is booted and I see the Windows7 / OSX choices. When I select Windows 7 I get the "Starting Windows" message and the puling Windows logo. After a few seconds the machine just reboots with no message displayed. I've done this several times with the same results. I've used the "Repair" option in Windows several times and each time Windows finds no problems.

If reboot and choose OSX I get to the Chameleon screen. I choose the OSX choice there. I get to the gray screen with the gray Apple logo and the spinning pinwheel. It grinds away for a while then displays a circle with a slash through it above the Apple logo and stops. I've retried that several times with the same results.

If I reattach the Windows drive to the Windows machine it boots properly. With the Windows drive removed from the OSX machine it boots properly. That indicates that neither drive is damaged in any way.

Has anyone experienced the same problem and know of a way to fix it?



Knows where his towel is.
Staff member
On the Windows machine I ran the installed EasyBCD 1.7 and deleted the entry for OSX and rebooted. I uninstalled EasyBCD 1.7 and rebooted. I then installed EasyBCD 2.0 and added the OSX entry.

I moved the Windows drive to the OSX machine. When the boot choice came up I chose OSX. It now boots properly. But if I choose the Windows 7 option I still have exactly the same problem described in my original post ( get to the "Starting Windows" with the Windows logo and the machine just reboots itself). Windows repair reports no problems found.

If it is of any help when I boot into OSX the Windows drive is mounted and I can access its files.

Is there some sort of editing I should do?

Thank you


Mostly Harmless
Staff member
press f8 after selceting windows, and choose "don't auto-restart"
Although I wasn't really looking to do it this way I found a way to get a working dual boot from Chameleon 2.0 instead of EasyBCD. On the OSX machine SATA is set to AHCI. On a hunch I reconnected the Windows drive to the Windows machine and changed the BIOS to set AHCI. When I tried to boot it failed with exactly the same symtoms as on the OSX machine. I then knew that AHCI was part of the problem.

The GigaByte motherboard I'm using for the OSX machine has 6 SATA connectors supporting AHCI and two that don't. I connected the Windows drive to one of the non-AHCI connectors, changed the BIOS to boot from the OSX drive and now everything works properly with Chameleon managing the dual booting.

I will still try your suggestion just to see if it helps.