OSX86 issue : how to customize chameleon RC4 used by easyBCD ????


i'm using easyBCD beta build 93 trying to boot to OSX86.
it's GUID partition on 2nd HD.
first HD is booting XP and seven with no problem.

i'm using mac OS efi mode.
it creates NST folder with autoneogrub.mbr and nst_mac.iso files.

boot is actually working, from chameleon RC4 installed by easyBCD.
the issue is it can only boot in 1024*768 mode, since it uses default settings.

My question is simple :
How can i customize that ???
change the chameleon bootloader with mine
adding info to com.apple.boot.plist or adding kexts ???

i tried to edit the nst_mac.iso from NST folder adding my boot file and kexts with no success.

how does this process works, where is chameleon RC4 is loaded from ?

many thanks for your help !


Mostly Harmless
Staff member
"no success" meaning (a) it won't boot, or (b) it doesn't recognize your files.
no success means it boot but still having the display issue.

i have made a perfectly working OSX86 SL with the myhack custom bootloader.
a mix of chameleon 2 RC4, PCEFI-10.5 and AsereBLN.

it works perfect when booting from itself. no graphical issue.

i tried to change the boot file from the nst_mac.iso with the myhack one but the bootloader remain the one from easybcd while booting.

i tried to remove all the files except boot and cdboot from usr/standalone/i386 - replace those remaining file with mine- boot with same issue

i removed all the kexts from extra and put mine - boot with same issue.

change the com.apple.boot.plist - boot with issue.

put them all together bulding a 7 mb iso... same result.

any idea ?



Mostly Harmless
Staff member
Can you explain how you made your mix and what it improves over EasyBCD's implementation of Chameleon?
not done by me.
It's myhack project.
you can find info here :
myHack Installer

it's the most efficient way i found to run 10.6.2 X64 OSX on my computer.
only had voodoohda.kext to extra to get sound working.

with the basic chameleon bootloader, it require more stuff to run perfect.
maybe the problem is more from kexts or com.boot.apple.plist, but everything i try failed with the bootloader from easybcd
Computer Guru, can you just tell me how that works.
where the boot file is loading from and if the EFI partition is used on the GUID HD.
my goal is to use my install bootloader.
would be much appreciate.
I've been experiencing the same problem as well. I assumed once I injected the smbios.plist from my chameleon install on the OS X HDD everything would run as it does booting off of that HDD. What is it that I'm missing?


Mostly Harmless
Staff member
I'm working on allowing it to be customized, but am really busy with some other things at the moment.
I am very interested too in customizing the nst_mac.iso

I spent the whole evening yesterday trying to customize, but every time I make modifications to the nst_mac.iso, Easy BCD beta build 95 cannot boot the iso anymore. It just stalls at the grub prompt.

I am still trying to figure out what the trick is to keeping the iso bootable after doing cutomizations.

Under Windows, I used MagicIso to edit the iso and save it, but it never boots anymore.

Under Mac, I used the built-in disk utility and the freeware application DMG Converter and sometimes Terminal commands to try to create the iso from scratch, but same thing. Easy BCD cannot boot the iso. It stalls at the grub prompt.

Computer Guru, I understand you're very busy right now. I'm looking forward for your customization method.

*** EDIT *** Actually, I believe what I really need is a nst_mac.iso without the Extensions folder. The custom kexts can be put in the Extra/Extensions folder of the Mac OS partition, that way it should work for everyone without the need to customize the nst_mac.iso.
Last edited:

In my experience the kexts in the Extra/Extensions of your root OS X HD will load fine regardless. My interest in customization is more fore being able to theme chameleon and have a proper resolution during boot.


Mostly Harmless
Staff member
Hi Jason,

Any word on whether it worked or not?
Add me to the list, I have a triple boot of Windows 7, Ubuntu 10.04 and Mac 10.6.3. It will boot Mac but will not recognize my video card and display. It only has a default setting of 1024 x 768. If I use the Chameleon on the drive with the Mac OS installation everything is detected correctly.


Mostly Harmless
Staff member
Again, try the preboot.dmg image.

And welcome to NeoSmart Technologies :smile:
First post here, just wondering why this thread died and I am trying to edit the iso or should I say add boot flags but cannot. Is this possible yet?