Partitions

#1
Hi,

Thanks for any help and advice.

I had dual boot (Windows Vista and Opensuse 11.1). Service Pack 2 came along and wrecked my machine and required repair installation - and wiped Grub. Also, i had to mark Windows partition of hard drive as "active" as this was the only way to get SP2 installed.

I have 2 problems:

1) My linux partition reports "no volume associated with this partition"

2) Grub and any linux bootloader entries were removed.

Windows Diskpart sees my partitions like this:

Partition ### Type Size Offset
------------- ---------------- ------- -------
Partition 1 Primary 504 GB 1024 KB
Partition 0 Extended 428 GB 504 GB
Partition 2 Logical 2055 MB 504 GB
Partition 3 Logical 20 GB 506 GB
Partition 4 Logical 406 GB 526 GB



Grub, sees my partitions like this:


Partition num File System Type
------------- ---------------- -------
Partition 0 NTFS 0x7
Partition 4 Unknown 0x82
Partition 5 ext2fs 0x83

Partition 6 ext2fs 0x83


I used EasyBCD and aded 2 entries:

Entry #1

Name: Windows Vista (TM) Home Basic (recovered)
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #2

Name: NeoSmart Linux Part 3
BCD ID: {20135dd3-f6ea-11de-947e-00248c0ddc44}
Drive: C:\
Bootloader Path: \NST\nst_grub.mbr

When i try to root(hd0,0) on Grub menu - or even just try and boot straight in to the "NeoSmart Linux Part 3" option - i always get:

Unable to mount disk or Insert System media and press any key.

Completely comfused and lost as to how :

to get my dual boot system back.
get linux partition working.
to know which partition to use in EasyBCD.

Microsoft SP2 wrecked my machine.

Regards, snapple
 

Terry60

Knows where his towel is.
Staff member
#2
When you originally installed Linux, presumably (either by intent or omission), you did not use "advanced" options when defining the bootloader. The default Linux action is to install grub to the MBR and the pre-existing boot partition, overwriting the Vista boot process, and taking control of the boot.
Microsoft, are a very egocentric lot. They assume that their software is in charge. Both SP1 and SP2 contained updated bootmgr, so the update replaced what it assumed was the old MS boot with the new version, and took control of the boot back.
Linux accepts that MS exists, so when it seizes control, it does at least give you an option to continue booting it.
MS doesn't return the compliment, it doesn't even recognize the foreign file system, certainly making no concession to attempting to boot it.
EasyBCD 2.0 latest build will create a bridge for you, but it has to have something to bridge to.
You don't have grub on your linux partition.
You will need to reinstall grub into the Linux bootsector (not the MBR) and then delete and re-add the Linux entry in the BCD.
 
#3
Hi Terry60,

Many thanks for your reply.

The default Linux action is to install grub to the MBR and the pre-existing boot partition, overwriting the Vista boot process, and taking control of the boot.
... that is what i had. I had a working dual boot system, where Grub was the bootloader, and Linux was the partition consulted for the MBR.

You don't have grub on your linux partition.
... why not? I dont see a reason why it would have been removed... its part of my opensuse installation (and i assume / hope, thats still there on my other partition) ?

I think i also have a lack of understanding about my partitions. I have managed to get to the Grub command line (with the help of EasyBCD, by marking a linux partition from the drop down menu as 'Grub is not installed' - and then when i chose this at boot time, it enters the Grub command line).

I'm not sure which partition to chose from the drop down menu in EasyBCD. Grub, Diskpart and EasyBCD, all appear to be reporting slightly different partitions (or, i guess, more likely, just naming / presenting them differently).

Many thanks for your time and help. I'm on an island here, and i dont know where to go for help.

Best regards, snapple
 

Terry60

Knows where his towel is.
Staff member
#4
You haven't got all of grub on your Linux partition, because Linux default action is to put some of it on the partition with the "boot" flag. ("system" in MS speak), which was Vista. That's how it takes over control.
You need to fix grub on your Linux partition as in the last part of the link I gave you. (The first shows how to put grub back in control as you had previously, but it will be vulnerable to future Vista updates if you choose that option, same as this time.)
 
#5
Hi Terry60,

Thanks for your continued help.

I think i'm in trouble. I ran:

find /boot/grub/stage1
and got:

Error 17: File not found
I must say now, that i have (over the last few days) been trying various 'root (hd?,?)' commands, because i thought that this would solve my problem. I hope i didnt do anything that might effect the execution of the "find" command? I doubt it, but thought i would check.

So how much trouble am i in, and how do i get out?

I had a lot of work, a mail server, webserver. tomcat server, and many hours of opensuse eye candy setting up - all on that partition.... is it time to kiss goodbye to it? I dont see how/why - the partition still seems to be there, and i haven't deleted or formatted it. And the most i have done with Vista is a repair install... which should respect partition boundaries.

Many thanks.

Best regards, snapple
 

Terry60

Knows where his towel is.
Staff member
#6
Perhaps this is a better guide
 
#7
Hi Terry60,

Thanks for your reply. I'll track down the opensuse 11.1 live CD. I've got serious bandwidth issues at home currently, and am awaiting an engineer to sort it out.

I'll read through the thread, give it a go later tonight and report back.

Thanks for your help.

One question: with the "find" command - does that search all partitions, or just the partition that i chose from the EasyBCD drop down menu? Is it worth me trying the same, but on different partitions (although i'm fairly sure i chose the right one, because all others were too small... i split my disk 50/50 at 504GB each).

Regards, snapple
 

Terry60

Knows where his towel is.
Staff member
#8
Yes, that's the point of "find". For when you don't know where it is.
 
#9
Hi Terry60,

I followed the advice here:

https://help.ubuntu.com/community/RecoveringUbuntuAfterInstallingWindows

However, when i booted from the Opensuse live CD, and went to the Grub directory - there was neither (i checked for both as i wasn't sure what Grub Opensuse 11.1 came with):

boot/grub/menu.lst
boot/grub/grub.cfg

So i am a little stuck. With "find" returning "File not found" and no Grub menu / config file... i'm unsure as to how to resolve my issue. From the live CD, i tried both "boot from disk" (which didn't work / wasnt allowed) and also tried booting from the live CD.

Many thanks for your continued help and support... believe me, its very welcome!

Best regards, Sam
 
Last edited: