PCLos won't boot but Mepis will.

#1
I've just "grasped the nettle" and set up a dual-boot Vista/XP system on my Toshiba (yuk) laptop with the help of EasyBCD. On other machines there has been little difficulty setting up a multi-boot systems - Win98/XP/Linuxs' - with the aid of BootMagic (but that is not an option where Vista and/or ntfs are involved).

Anyway I installed PCLos which went smoothly. requesting Grub be installed in the root partition.

Back in XP (or Vista) pointed EasyBCD at the PCLos partition and rebooted. Unfortunately selecting PCLos from the BCD menu results only in a cryptic message pointing to "winimage.com..." (don't go there)!

For further testing, I installed Mepis into another partition and went through the same setup routine and it boots perfectly from the BCD menu - but PCLos still doesn't.

The issue is further confused by GParted seeing the partition as sda10,menu.1st as hd0,9 (and a UUID) and EasyBCD as partition 8 (it starts from 0 and doesn't assign a number to the extended partition)!

When adding Mepis within EasyBCD it points to nst_grub_<hexID>.mbr but for PCLos just nst_grub.mbr?

[On the non-Vista machines, multiple Linux distros - including PCLos and Mepis - are automatically detected and made available for adding to the menu]
 
#3
Hi, kairozamorro

Perhaps I was unclear. That's what the entry for PCLos IS!

Mepis entry> Bootloader Path: \NST\nst_grub-8E6024C34A57332596B22A97E2015FC2.mbr - Works

PCLos entry> Bootloader Path: \NST\nst_grub.mbr - Does NOT work

Addendum:

Now resolved (rather than solved)!

Reinstalled PCLos...

Although menu.1st and the EasyBCD entry appear to be the same as before it now fires up!
 
Last edited: