Pentium 4 Has Lost Its Hyperthreading

Ex_Brit

Super Moderator
Staff member
In Vista I noticed that my computer was not coping with the same heavy loads as usual and looked in the task manager. Only 1 CPU showing when there always used to be 2. I know that Pentium 4 is only 1 CPU but it shows as 2 in TM when 1 graph per CPU is selected.

I did set NUMBER_OF_PROCESSORS in CMD Prompt and it told me that I only had 1 (should be 2 if HT enabled).

It's acting as it should in XP and Windows 7 - only Vista is effected and in the attached picture that Processor name spelled out used to read merely ACPI Multi-Processor (or words to that effect).

I've tried disabling HT in the BIOS rebooting and then re-enabling it again but it had no effect.

What to do?
 

Attachments

Last edited:

Ex_Brit

Super Moderator
Staff member
Tried that but on second thought it wouldn't help as this is really a hardware issue with Vista recognizing it. When I've finished burning the DVD I'm doing right now I'll uninstall the processor in device manager and reboot. Hopefully the system will re-enable the HT.


Addendum:


OK cured it.

I found this method online posted by someone who had a quad-core showing as only 2 so adapted it to suit.
In the Device Manager shown above I uninstalled both the Processors and rebooted.
They duly reinstalled and I had to reboot again.
Then I went to Start/Run and entered msconfig, OK'd UAC and once it opened went to the Boot tab/Advanced Options
There I unchecked the number of processors (which showed as only 1)
I then checked "Detect HAL" and rebooted.
Eureka....it worked.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
weeeeeeeeeeeeeird
 

Ex_Brit

Super Moderator
Staff member
Yes indeed, very weird. I think I have a ghost. My TV turned itself on the other day, would that count as weird?
 

Terry60

Knows where his towel is.
Staff member
Only if it was unplugged at the time !
 

Ex_Brit

Super Moderator
Staff member
LOL, now that would freak me out.
 

JustinW

Super Moderator
Staff member
You can also control the proccessors for entries using EasyBCD too...
Can't help you with your ghost problems though :smile:
 

Ex_Brit

Super Moderator
Staff member
LOL, thanks Justin. I have EasyBCD installed in XP which is my other hard drive, would that make a difference? The only OS this happened to was Vista for some unknown reason.
 

JustinW

Super Moderator
Staff member
Nope. In advanced options you can set the number of proccessors for an entry, specifying 0 to reset it.
 

Ex_Brit

Super Moderator
Staff member
That's handy to know. Never looked at that option before. Thanks for that info.:smile:
 
Top