Please help! Vista - Service Pack did not install. Reverting changes.

#1
I have a PC running Vista SP1. Apparently a member of my family (SWMNBN :smile: ) chose an option to allow Windows to automatically install updates. I found this out when the PC got stuck while booting up with the following message:

"Service Pack did not install. Reverting changes. Do not turn off your computer."

I can only guess that it was a result of a failed SP update. After leaving it running for hours without any progress I decided to search for help and came across your Vista Recovery CD. I downloaded and made a boot disk. When I used the Start Up repair option it came back with "Startup Repair could not detect a problem." I've made multiple attempts at repairing with the same result.

This is an older PC and I don't have a backup to restore from. I'd appreciate any suggestion you may have. Thanks!

Tom
 

JustinW

Super Moderator
Staff member
#2
Its not anyone in your family to blame. That's how Windows is set up by default (which is typically a good thing). System restore from our recovery disc is about the only way to put it back to pre-SP1 condition.
 

mqudsi

Mostly Harmless
Staff member
#3
Justin, I think it's the default option, but it's not enabled until you actually press "OK".

But, yeah, I think it's probably been always that way :smile:
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#4
Tom - reset updates to notify you first in future. I strongly recommend that you install the service packs for security and serviceability reasons because eventually Vista sans SP's will be unsupported. The usual barrier to the SP's installing is anti-virus protection which must be disabled temporarily until the operation is successful.

Make sure all other updates are installed and then retry using any tips you may find useful here. (I'm a Moderator at the McAfee Security Forums so forgive the plug).
Tips on Installing Vista SP1 and Tips on Installing Vista SP2.

By the way, in the above case booting to Safe Mode and selecting "Last Known Good Configuration" would probably work, no?
 
Last edited:
#5
Thanks for your input, everyone. I'm unable to do a system restore with the recovery disc. About the only thing it lets me do is access the command prompt. Is there anything I can do at that point?

Peter - I've tried booting to Safe Mode and selecting "Last Known Good Configuration" and ended up at the same screen: "Service Pack did not install. Reverting changes. Do not turn off your computer." :frowning:
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#6
That "reverting" screen can take an absolute age to complete, are you sure it never finishes? It can take hours on a slow machine.
 
#7
That's good to know, Peter. I've left it running for as long as about 6 - 7 hours the last time but didn't really keep track. Should I let it run even longer?
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#8
I would at least try it, otherwise follow Justin's advice given earlier to see if you can restore the machine to an earlier state. It does seem an awfully long time to take but I do know from experience with my old rig that it can be frustratingly long. I was about to give up and format the hard drive when suddenly it completed.

In Safe Mode I don't suppose you can access Windows at all? If you could you could then initiate System Restore from there.
 
#9
I've tried the restore options with the recovery disc but it did not find a point to restore to. I've also tried various Safe modes to boot without luck.

Is there anything I can run at the Command Prompt to diagnose or disable/enable the boot issue?

For now I'll let it run until this evening and see. Thanks for the suggestions, Peter.
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#10
That's where my knowledge gets a bit hazy. Justin or Mahmoud...any ideas?
 

JustinW

Super Moderator
Staff member
#11
SFC maybe....

sfc /scannow /offbootdir=c:\ /offwindir=c:\windows\

It probably can't fix it though. Time to look for the Windows disc for re-installs or a recovery set as our recovery disc doesn't contain any installation files. Use a Ubuntu disc to rescue your data.