Problem after moving Win7 boot files

Don't know that this is a "bug" -- since it works now -- but thought it worthwhile letting you know about it ...

Installed Win7 Pro in unallocated space on a drive. Win7 allocated the 100MB boot partition as well.

Few days later, used EasyBCD (build 133) to move the bootloader files to the Win7 OS partition. Seemed to go OK. Reboot was fine.

Then yesterday, downloaded and installed build 137. Ran EasyBCD and it errored out saying it couldn't find a valid BCD. Went to locate the BCD manually. When I checked the file, EasyBCD errored out saying the file was in use!

Rebooted PC using the Win7 DVD to do startup repair. Would boot to the wallpaper but never got the following menu. Tried this several times --- same result.

Stuck in previously-burned Win7 Repair CD, booted using that, ran Startup Repair. Said it found a problem and fixed it. Ran it again. No problem this time.

Rebooted from the HDD. Booted fine. Reran EasyBCD. Found BCD time time no problems.

So, something got corrupted during the boot files migration. Not enough to prevent subsequent booting. But enough to prevent EasyBCD from working.
Update: Have confirmed that this is NOT a problem with EasyBCD.

I had the Macrium Reflect Boot option installed in the BCD. Today, I was on the MR forums and noticed another poster with the same problem. It appears now that the presence of the MR boot option is the problem.

Once Startup Repair is run from the Win7 DVD, it removes the MR boot option -- and all is well again.

That boot option also prevents the successful installation of Win7 SP1.


Mostly Harmless
Staff member
I could have sworn I replied to this thread...

Anyway, what I said was that it's *not* an x64 issue, since all my EasyBCD development is done on a 64-bit PC.

I guess the Macrium code is garbage. Good news is you can use EasyBCD to add a "proper" Macrium entry in the bootloader.