Problem: Linuc new entry never saved

vibi

New Member
#1
Hello all,

new in the dual boot area...
I just installed Ubuntu 8.10 on its own partition, and (hopefully) I've put GRUB on the Ubuntu partition. The machine I'm working on is a Vista Sony laptop.
I used EasyBCD to modify the vista bootloader to enable Ubuntu, following the tutorial I've found on this web site. I selected the 'GRUB is not installed to the bootsector' check box in the 'Linux' tab of my new entry.
It seemed to work, as the 2 options Vista and Ubuntu were shown during next reboot. But, if I chose Ubuntu, I would only get a GRUB> prompt, with no way of doing anything else.

So I browsed the web a little bit and found out a note somewhere saying that the NeoGrub had to be uninstalled (how come it was installed in the first place, I wonder!!!!), and the Linux entry had to be deleted, then recreated.

Which I did... but now, the problem is that the nex Linux entry gets never saved in EasyBCD. It never appears on the list of saved entries, and obviously, my laptop does not show any dual boot anymore. I only have the Vista boot!!

Can sombody tell me what I did wrong and what I should do now?

Thanks

Vincent

Addendum:

Guess what... taking a glass of water helped!! I don't know what happened really. I tried everything, rebooting and so on, with no success. I browsed through the various options of the tool, did not see anything which had changed, tried it again just to make sure... and it worked!!

So, ok, let's forget about this, it is working fine now. It set it without checking the 'GRUB is not installed to the bootloader', hoping this will not lead to further issues later on...

It'd be good to understand why Neogrub got installed anyway in the first place.

Cheers

Thanks
 
Last edited:
#2
Hi vibi. Welcome to NST.
Glad your problem was fixed...before anyone had a chance to post ! :brows:
Stick around. We'd love to have you in the forums.
Drop by the Water Cooler sometime. :smile: We welcome new members.

-Coolname007

EDIT: Oh, and the reason why NeoGrub was installed automatically was because you selected the "Grub isn't installed to the bootsector" box, which installs an automatic version of NeoGrub that reads the menu.lst on the Linux partition, and not the one on the Windows partition at X:\NST\menu.lst where "X" is the drive letter your partition is. Unfortunately though, that often doesn't work (that is, checking that box...), because the Ubuntu menu.lst usually has "uuid" lines in it which aren't supported by NeoGrub (except for the latest version, which is included with EasyBCD 2.0, which hasn't been released yet).
 
Last edited: