Problem - New drives become Drive 0 and are labelled "system" in Vista

#1
I have taken the Vista plunge, and I have a problem. I knew Vista would have issues with multiple drives during installation (has there been a MS OS yet that hasn't has issues?) so I dutifully unplugged all my hard drives except my 2 SATA drives running in RAID 0. I installed Vista (after loading my RAID drivers from a USB drive during installation) and everything was fine. In disk management, I had Disk 0 (being my C:smile: and CD-ROM 0 (being my DVD drive). Now came time to plug my other drives back in (3 PATA drives, all simply used for data storage). I booted into Vista and all the drives were there (yay!) however I wanted to change the drive letters of the newly plugged in disks. I went into disk manager, and I see all the drives, but they are in an unexpected order: Disk 0 is my first PATA drive, Disk 1 is my second PATA drive and Disk 2 is my third PATA drive. My C: has been shuffled to Disk 3. I thought to myself "no worries - so long as the disks are there and I can change the drive letters. I'm happy". Sadly, I cannot change the drive letter of Disk 0 because Vista has designated it a "System" drive (why??) and I get the error telling me I can't change the drive letter. If I unplug all my PATA drives, my C: returns to being the "System" drive (as well as being a boot, page file, active, crash dump and primary partition drive). As soon as I plug in any new drives, they shuffle my C: down the order and whatever is Disk 0 is designated a "System" drive. This has further implications beyond not being able to change the drive letter too. If I do a backup with the backup control panel, it forces me to include Disk 0 (because it is a "System" drive), which may have 200 gig of MP3s on it, which I don't want to backup. Plus it won't let me do the backup onto Disk 0, which is a pain because that might be the drive with enough space to do the backup at the time, if only it would let me exclude it from the backup in the first place! Another problem is the "System" drive cannot be formatted. There is absolutely no system information on this drive, and I might want to format it (causing my system no damage) but Vista won't let me (it's greyed out).

I downloaded EasyBCD and re-wrote the MBR but it doesn't change a thing. What I really need to do is to force Vista to see my drives in the normal order (RAID array as Drive 0, and other drives after that). It used to be in the correct order in XP, and I never had any problems (and I haven't changed any BIOS settings between XP and Vista). Is there a way to force Vista to play ball and order these drives correctly, or am I stuck with one of my PATA drives always being labelled "System" and therefore not being able to backup properly or format the drive?
 

mqudsi

Mostly Harmless
Staff member
#2
Hi blamesociety,

Welcome to NeoSmart Technologies. In answer to your question - you are stuck indeed.
What caused this is that you removed the system drive and proceeded to install Vista, thus creating the need for a new system drive - something you should never do.

Now that it's been done, you'll probably have to live with it.

You can fix this problem, but it won't be fun.

Start by deleting the Vista boot files (bootmgr and the boot folder), booting from Acronis or Partition Magic live CD.

In the BIOS, make sure the correct drive is set as the system drive.

Once that's done, boot into XP and install EasyBCD 1.61 BETA there.
Diagnostics | Recreate Boot Files

It will ask you for the correct boot drive and the Vista drive; then recreate and reset the Vista bootloader to the correct drive.

A pain in the ass really, it all depends on how badly you need to make this problem go away; though many people just don't bother.
 
#3
What caused this is that you removed the system drive and proceeded to install Vista, thus creating the need for a new system drive - something you should never do.
I didn't remove any "system" drives... I just unplugged all my hard drives other than my main drive (the RAID array).

Now that it's been done, you'll probably have to live with it.

You can fix this problem, but it won't be fun.

Start by deleting the Vista boot files (bootmgr and the boot folder), booting from Acronis or Partition Magic live CD.

In the BIOS, make sure the correct drive is set as the system drive.

Once that's done, boot into XP and install EasyBCD 1.61 BETA there.
Diagnostics | Recreate Boot Files
I don't have XP installed... I only have Vista. This is not a dual boot problem - Vista is all I have! None of the other drives have any operating systems on them whatsoever.

It will ask you for the correct boot drive and the Vista drive; then recreate and reset the Vista bootloader to the correct drive.

A pain in the ass really, it all depends on how badly you need to make this problem go away; though many people just don't bother.
But it is preventing me from using the drive to backup to, preventing me from changing the drive letter and preventing me from formatting the drive, even though there is no system on this drive at all...

Just to be clear - this is a totally clean installation. I removed all my drives except the two RAID drives I wanted to become my C: and installed Vista on that RAID set. I do not have XP or anything else installed.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
I'm sorry - your original post confused me with the final reference to XP.

This certainly is an interesting bug.
Is the viewing of System Files enabled?

Tools | Folder Options | View
Show Hidden Files [X]
Show System Files [X]
[OK]

Sorry for the original confusion, but I understand the problem now.
(Not an EasyBCD issue btw, so moved to correct location)

If indeed - even with viewing of system files enabled - there aren't any system files on the data drive, go into your bios and take a look at the order of the drives there in the "Drive Configuration" section.

I know you said you didn't change anything, but it could possibly be that Vista is reading them right and XP read them wrong... just possible.
 
#5
Sorry I posted in the wrong forum :shame:

With view hidden and system files enabled, I have the following files and folders in the root directory of my C: (other than the normal files):

Directories:
$Recycle.Bin
Boot
System Volume Information

Files:
autoexec.bat
bootmgr
bootsect.bak
config.sys
grldr
hiberfil.sys
pagefile.sys

On my other drive (the one that disk manager insists is a system drive and won't let me format or change the drive letter):

Directories:
$Recycle.Bin
Boot
System Volume Information

Files:
autoexec.bat
boot.ini
bootmgr
config.sys
io.sys
msdos.sys
ntdetect.exe
ntldr

Disturbingly, boot.ini contains this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

I have never had XP Home installed in my life (I don't even have a copy of it on CD...)

If I remove my second hard drive, my C: becomes the "system" drive but none of the files that were present on my other drive appear on the C:

I have no idea how the other files got on my second drive. I guess the question is, if I delete them, will my drive be back to normal? Of course, the question then becomes, how do I delete them when they are protected system files (even though they appear to have nothing to do with my system...)?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
OK, get Acronis Disk Director, Paragon, Partition Magic, etc. and create a bootable partition CD.

Boot from it, select the partition you want and change its propetry to "active" then boot from the vista dvd and repair startup.
 
#7
Thanks for your help and advice. I have now fixed the problem. All I did was pull out the offending drives, stick them in an external USB enclosure, back up the data on them and format them. Now when I stick them back in my PC they are no longer marked as "system" drives (it must have been the system files that somehow got on the drives fooling Vista into thinking they were indeed system drives). They still take over Drive 0, Drive 1, etc, pushing my C: down every time I add a drive, but that doesn't bother me. I can now change the drive letters of my data drives without it complaining that they are "system" drives, and more importantly, I can use the Vista backup control panel and it doesn't force me to backup my data drives, just my C:
 

mqudsi

Mostly Harmless
Staff member
#8
Well, glad to hear you got it to work; regardless of the method employed.

Thanks for posting back to let us know how it went, I'm sure this will help someone else down the road - many people do not have the decency to post back once everything is going well - kudos to you!
 
#9
many people do not have the decency to post back once everything is going well
I know - I really hate that. The Internet is littered with forums where people post problems they are having, and many possible solutions are suggested, but often the original poster never comes back to say which method worked, if any, meaning people have to ask the question again or try one of many different methods not even knowing if one of them actually works.
 

mqudsi

Mostly Harmless
Staff member
#10
I guess we'll just have to do our best to clean up the forums we come by, one at a time :smile: