Problem Win7/Fedora 12 dual boot

#1
I have a window 7 machine w/ one HD. I loaded Fedora 12 on empty space on drive created a / partition and /swap partition w ext3 format. I installed EasyBCD 2.0 beta 76 and tried to setup a linux boot.

1. I used legacy grub w checked box as I have installed grub to the /boot directory and not into MBR. This failed.
2. I tried Neogrub and copied my menu.lst file into it and this failed.

It seems I cannot get to the linux grub as I always get dumped to the gub4dos box.
Under neogrub if I type configfile /NST/menu.lst I can see the grub entires there. I can even type root (hd0,2) and get access to the ext3 root Fedora 12 partition. However when I execute the kernel /boot/vmlinuz.... line it fails with error 2

I changed kernel line from root=UUid... to root=/dev/sda3 and this fails as well.

I also reinstalled grub from the live cd to the partition as well and still the same. I know the correct files are in /boot and /boot/grub but the neodos can't see them.

Any ideas
 

Terry60

Knows where his towel is.
Staff member
#2
Go back. Delete the Linux entry from the BCD.
Add it again
Select grub2
 
#3
Thanks for the help, but I did try this as well, even thoough Fedora does not use grub2. They are using a bastardized .98? version of grub that supports ext4 it seems. Any idea when the wiki will be up so I can check if I missed something for Fedora or is there any other place that might have the Fedor instructions mirrored. Thanks again for your help
 

Terry60

Knows where his towel is.
Staff member
#4
If you know it's using legacy grub, then follow the advice about when (not) to tick the box in the sticky point 7 para 2.
 
#5
I've tried check and uncheck. When I uncheck I don't get dumped to grub4dos only a black screen and I need hardware reboot. I've read every related link on this forum and many have had similar problems yet in the end they solved it. I have tried many of their solutions but none worked.
 
#6
Also, from the neogrub prompt if I configfile /NST/menu.lst the file comes up, but if I try configfile /boot/grub/menu.lst I get file not found error. Now I know these files are there and it is a good partition as I have mounted and viewed the directory /boot and its contents with a live CD and even have reinstalled grub to the partition. Its driving me crazy. I can type root (hd0,2) and it works and I switch to the partition, then why can grub also read the files from here while a livecd has no problem. Somewhere I read that neogrub doesn't handle ext3 partitionw w/256 inodes or something like that. Could it be this?

Addendum:

I think I know what the problem is but do not know how to fix. This is a laptop with a new 160GB HD. I patitioned one 110GB for windows 7 and 50gb for fedora / and /swap. I should be able to see grub as it is within 137gb limit. Any takers for this?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#7
That was an old issue that has since been resolved. Now NeoGrub supports 256+ inodes and ext4fs.

Now, to the best of my knowledge, Fedora doesn't use /boot/grub/menu.lst but rather /boot/grub/grub.conf
 
#8
Thanks for all the help. The issue was I have a laptop whose latest BIOS has a 137 GB HD limit. Under these conditions one can install Windows 7 as long as the partition is less than this limit, in my case I used 100GB of 160GB drive. My mistake was thinking I could load Fedora on only 2 patitions namely / and swap. I thought that the boot part on the main / patition would still be below 137GB and I would be good. No go. I needed to reinstall Fedora 12 with 3 partitions namely /boot(1GB), /(48GB), and swap(2GB). I guess the whole boot partition needs to be below 137GB. When I did that EasyBCD worked straight away with Legacy grub and the box checked. Dual boot heaven. This should be a note to all those who have laptops circa 2003-2006 where the bios does not support large hard drives in my case it was a Dell Inspiron 6000
 

mqudsi

Mostly Harmless
Staff member
#9
Wow.. I completely and entirely forgot about the 137GB limit.. it's been sooooo long since I had a user with that problem that it slipped my mind entirely.

But, yes, you're right. If the BIOS doesn't support LBA and 137GB+ hard disks, the bootloader (any one, and in this case, NeoGrub) which talks to the hard disks via the BIOS APIs cannot read past that 137GB marker.

Glad you got it working and thanks for bringing this to my attention once more.

Enjoy your dual-boot and have a great day :smile: