Problems booting with GRUB/EasyBCD

#1
Hello all, my computer setup looks like this. It originally had Windows 7 and then i later installed XP on the 2nd partition. I got it all booting fine with EasyBCD, giving me the option to boot into either.

Now i just installed Ubuntu last night and it looks like GRUB might have messed some things up. I decided to try to fix it on my own so i went into EasyBCD and reinstalled the original bootloader. Now it looks like this when i boot up..

1) Windows 7
2) WinXP
3) Ubuntu 9.10

BUT, for some reason, the only one that actually works now is windows 7! i will post the error messaged below if they provide any help. i obviously screwed something up when i installed Ubuntu and erased GRUB, so simply enough, how can i make my boot up menu look like the above with working operating systems?





Here are my errors when i enter each boot option

2)WinXP - "windows could not start because the following file is missing or corrupt:
<Windows root>\system32\ntoskrel.exe. Please reinstall a copy of the above file
3) Ubuntu- "Try (hd0,0): EXT2
 

mqudsi

Mostly Harmless
Staff member
#2
Are you using EasyBCD 2.0?
 
#3
Im using easybcd 1.7.2. should i try the other one?

update: i went ahead and got 2.0, Xp boots up perfectly now, but ubuntu is still not seeming to work. so thats at least 1 step closer haha
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
You need to select "GRUB2" from the drop-down menu in the Add/Remove section, not the default (which is for older versions of Ubuntu).
 
#6
BUT, for some reason, the only one that actually works now is windows 7! i will post the error messaged below if they provide any help. i obviously screwed something up when i installed Ubuntu and erased GRUB, so simply enough, how can i make my boot up menu look like the above with working operating systems?
How did you "erase" Grub? Delete the grub folder?

Addendum:

i tried that too and it still has the same error
And which error is that exactly?
 
Last edited:
#7
same problem

I'm having the same problem.

I have Ubuntu 9.1 and installed Vista home edition afterwards.

Trying to boot Ubuntu gets me the

try (hd0,01): EXT2:

I've tried to every option in the linux drop down menu given (Grub legacy, grub 2 etc...)
 
#8
How did you "erase" Grub? Delete the grub folder?

Addendum:


And which error is that exactly?

a) Maybe thats not exactly what i did. I went into EasyBCD/clicked manage bootloader/ then clicked write MBR. i read on a forum somewhere this deleted the grub but maybe im wrong

b) the error.... try (hd0,0): EXT2
 
#9
Maybe try using the "Grub is not installed..." option, under the Linux tab, when you add a new entry?
 
#10
Maybe try using the "Grub is not installed..." option, under the Linux tab, when you add a new entry?
I tried doing the GRUB option where u can check the "grub is not installed" box, and i also tried the GRUB2, but that "grub is not installed" check box dims away when u set it to GRUB2. both dont seem to work :frowning:
 
#11
Could you post your NeoGrub menu.lst?
Just go to EasyBCD->Add/Remove Enries/Neogrub tab/Configure, and then copy the contents of the file over into your next post.
 
#13
The configure box is greyed out. Thats probly not right then is it?
NeoGrub (with its menu.lst) is supposed to be installed when you check the "Grub is not installed..." box underneath the Linux tab in Easy. Did you create a new entry with that option checked?
 

Terry60

Knows where his towel is.
Staff member
#14
That option only applies to legacy grub. Grub2 doesn't need it. (hence the greying)
 
#15
That option only applies to legacy grub. Grub2 doesn't need it. (hence the greying)
True, but he said he tried doing the Grub legacy, with that option checked.
I tried doing the GRUB option where u can check the "grub is not installed" box, and i also tried the GRUB2, but that "grub is not installed" check box dims away when u set it to GRUB2. both dont seem to work :frowning:
But I wanted to check to see if he actually tried creating the entry.
 
#16
Erasing / Uninstalling BCD

I would like to remove my BCD startup menu from my MBR because now I have both a BCD and Grub Menu. After using the BCD menu to select linux, I select an option from the Grub menu - e.g Ubuntu 9.04. I don't need both menus. Any advice?
 

Terry60

Knows where his towel is.
Staff member
#17
In ubuntu, change the boot/grub/menu.lst timeout value to 0.
(gksudo gedit /boot/grub/menu.lst)

The grub menu won't be presented, it will just take the default (1st ) option, Vanilla Ubuntu.
 
Last edited: