Problems Installing & Registering Nero 7

Ex_Brit

If you're going through hell, keep going.
Staff member
#1
...does Vista speak another language when one is copying and pasting something from an email to a registration box?

I paid for and downloaded Nero 7 Enhanced (7.7.5.1 for Vista) and it refuses to accept the serial number they emailed me.

I've removed, used their Clean Tool, reinstalled...at least 6 times now. Even cleaned the registry out toally of anything "Nero" or "Ahead". I also tried entering it manually, still no joy.

I tried the same exercise in XP and it worked just fine.

Nero support is pretty useless I am finding.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
I have had no problems with installing Nero. I installed 7.5.7.0 and it installed and everything just fine. It runs without any issues. It might be the version i dont know for sure.
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#3
I meant 7.7.5.1, sorry - it's the only version that is (supposed to be) Vista compatible. It's strange. One suggestion was to disable UAC but that made no difference either.
I have Nero 6 on my XP drive but that shouldn't be interfering.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#4
I dont know about which version is the first Vista COmpatable but i do know that i have version 7.5.7.0 up and running with no problems. Maybe see if you can download that version somewhere and use your serial to install it and see what happens.

I also have Nero on my XP isntall and it doesnt affect me none. :unamused:
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#5
For Vista I have to use the latest version or else there will be problems. I tested it by installing it in my XP partition...no problems registering the serial number.
Back to Nero 6 there as I don't want to tempt fate.

Note that I also tried installing the demo version, it wouldn't accept its own serial number either.
What in Vista would cause software to ignore or reject its own serial number?
 

mqudsi

Mostly Harmless
Staff member
#6
That's really weird :S

I dunno - did you try running it in compatibility mode? I know it says it's compatible, but obviously they're wrong... Maybe Ahead DE never tried to register it on their dev PCs??

Is it a final version or a beta?

(I use and recommend ImgBurn instead. It's a hell of a lot more powerful, though slightly harder to use - and it's totally Vista compliant and totally free too.
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#7
I tried everything that you or anyone can think of, believe me! I'm still for them to reply. Their trial version wont accept its own serial number either, so I suspect as you say, this is not totally compliant.
 

mqudsi

Mostly Harmless
Staff member
#8
Well I certainly trust you've thought of everything I can think of and then some - is your trial over?
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#9
Never had a trial version....but this particular experience is a trial of its own I guess.
The trouble is that I'm used to Nero and like it...when it works...LOL
 

mqudsi

Mostly Harmless
Staff member
#10
Lol, I was the same with Roxio (Yeah, yeah, I know)
Everyone was using Nero, but I liked Easy CD Creator.....
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#11
Well, I solved the problem the brutal way. I formatted and reinstalled Vista and installed Nero 7 before anything else went in...worked. Lord only knows why.
When are they going to invent error pop-ups that give you a word-for-word reason for the error?

This was a breeze compared with an XP installation...Vista installs in a flash and I don't have that many programmes running in it.

Now my EMC Dantz Restrospect Express HD doesn't work and the usual repair option is absent. Plus their forums are about as much help as a boiled cabbage.
 

mqudsi

Mostly Harmless
Staff member
#12
Damn... that sucks!!!

I guess Nero is important to you, eh?
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#13
Well the aoftware that isn't working now is for backups and I can use Windows for that anyway. Not too worried.
Serves me right for going for a system that's still in its infancy.