Problems with a Vista/OSX/Recovery install

#1
Hi,

Well, I've been learning an awful lot about how Vista boots! Sorry for this book of a post, but I'm partially recording what I've been doing for the last two days... skip to the end if you don't want to read the back story. :smile:

I have four partitions - a recovery partition, vista, OSX and an extra 3GB partition that's empty at the moment. I can't boot any of them.

I used EasyBCD to try to add the OSX partition. Each time I booted, it gave me "application is missing" errors with status 0xc000000f. My last attempt was to delete all the entries, re-add vista and re-add OSX. When I rebooted, only the OSX partition was offered to me by the boot manager. This is the state that I'm in now.

I haven't been able to get into the recovery partition for awhile from an earlier problem (involving GParted, resizing the vista partition (to create the four I have now) and screwing up BCD in the process). The recovery partition BCD entries are corrupted. I attempted to fix the vista partition by using bcdedit to rebuild them - while I was in the recovery partition. Amazingly, the computer would boot the real partition, but only if I hit F11 (to get to the recovery partition). Because F11 was taking me to the real partition, since then, there's been no way into the recovery partition.

Interestingly, in my first attempts with EasyBCD, that changed. I could suddenly boot directly into the vista partition without going to the recovery partition... of course, F11 no longer took me to that recovery partition....

This is a ThinkPad x61t, so no floppy and no dvd drive. I have a Vista installation DVD and a couple extra computers.. if I could network boot the installation disk, I might be golden... but that doesn't seem likely. (No windows 2003 server and it's been a long time since I ever knew how to use tftpd32...)

I've tried a lot of different things. I thought it was a problem with the MBR so chased that dead end for quite awhile. IBM has a utility (for floppies) that will restore the MBR to the rescue partition. I managed to make a UFD bootable (using BootFlashDos.exe - a very nice utility), then copied the files from the floppy to the drive. This worked, except that it would only reset the MBR of the harddrive. Since the flash drive was presenting itself as C:, that means it would only change the MBR of the flash drive... not so useful. In the process, I also learned about syslinux and memdisk - beautiful utilities that really open up possibilities for booting from non-standard devices. The only problem there was that memdisk has problems specifically with ThinkPad hardware...

The final solution to the MBR (non)issue was grub. I found on the ThinkWiki that grub could be used to boot the rescue partition. So I installed it from a USB version of linux I had around (the GParted image where all these troubles began). It worked perfectly. So now I can use Grub to boot directly to... (drum-roll please)... the Windows Boot Manager. Which of course leads me right back to where I started: bad BCD entries and no way to fix them. I can boot to both the vista partition and the recovery partition. Vista gives me status 0xc000000f and \NST\nst_mac.mbr missing or corrupt. Recovery gives me status 0xc0000225 and \Windows\system32\winload.exe missing or corrupt.

---

Okay, if you're still along for the ride, I'm left trying to figure out how to change the BCD entries without vista around. I could install an operating system (linux would be easiest.. maybe DOS second) into that 4th partition. Or I could run a utility from either a DOS UFD or a (stripped down) linux UFD.

I'd really appreciate any suggestions you can offer.

Thanks!
Rudy
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Rudy, welcome to NeoSmart Technologies & sorry for the late reply.

I'm afraid that's simply not possible :frowning:
Only ways known to man to edit the BCD:
  • Windows Vista via EasyBCD or bcdedit.exe
  • Windows 98-XP via EasyBCD
  • Booting into the Windows Vista DVD -> Repair Options -> Command Prompt
That's about it. You can't use a bootable DOS cd (no .NET 2.0, hence no EasyBCD) and you can't modify anything to do with the bootloader from within *nix.

Possibly the Vista DVD option is your best shot?
 
#3
That's disappointing. :frowning:

Have you heard of BootItNG? It seems like it's a bootloader (albeit, a large one) that can edit the BCD. I found it while doing (yet another) google search...

The other alternative - I understand there are some LiveCD images that run Windows. Perhaps I could run one from USB?

Does EasyBCD have to be run from the physical drive that it is fixing?

Thank you!
Rudy
 

mqudsi

Mostly Harmless
Staff member
#4
Yes, BootItNG is an old boot manager that's been around from the 90s (paid), that's been updated with a minimal BCD editing interface for the program.

It's a bootloader manager, but if you want to modify the Vista bootloader you'll have to be in Windows to do so:
Compatible with all Windows versions (9x/ME/NT/2K/XP/2003/Vista).
Compatible with x64 (AMD64/EM64T) and Windows 64bit OS (non-GPT).
OK, I re-read through your first post, here's what you need to do:
Install EasyBCD somewhere.
Browse to C:\Program Files\NeoSmart Technologies\EasyBCD\Bin\

Copy bootsect.exe from there to a floppy disk.

Use a Windows XP boot CD on the PC you want to repair. Get into the recovery console. cd into drive A: and do this:
Code:
fixmbr
fixboot
bootsect.exe /nt60 all /force
exit
Maybe that'll do the trick.

If you installed Windows XP to a new partition, you can run EasyBCD from there, get everything working, then delete that partition again. Would that suite your purposes? It's by far the easiest solution for this problem.