Problems with vista, xp, opensuse and easybcd

NaYoN

New Member
#1
So, I have Vista. I installed opensuse on a different partition and vista stopped working. I discovered over the net that I can use EasyBCD or Vistabootpro to fix it. I installed XP on another partition, and opensuse stoped working. I tried to fix the Vista boot with the Vista CD, but my Vista CD isn't a full install, it's a "upgrade from XP", and it didn't work, it tried to install Vista, which got stuck at %27. Then I canceled it, and after some problems, was able to run XP. I used Vistabootpro to fix Vista's boot, then Vista started to run, but Xp stopped running. When I tried running XP, the Vista install stuck at %27 would run. I used Vistabootpro to fix XP from Vista, but it didn't solve my problem. I downloaded EasyBCD, figuring it's the solution to all my problems, but when I execute the installer in Vista (UAC turned off) the window appears and noting happens, so basically it does not work. Right now, I can't use my XP and my opensuse. Can someone please give me some advice?
 

mqudsi

Mostly Harmless
Staff member
#2
Your first mistake was in using VistaBootPRO - it only works if your computer is already mistake-free and has no errors in configuration. Otherwise, it'll screw it up more.

What do you mean by "the window appears"?
 

NaYoN

New Member
#3
Well, I opened it to take a screenshot, but now it installed fine... Now I'll try to fix my problems. Thanks for the prompt reply anyway.
 

mqudsi

Mostly Harmless
Staff member
#4
No problem. I thought it was weird!

So, what you need to do:
EasyBCD | Diagnostics | Reset BCD Data

Then add an XP entry in EasyBCD and ensure that boot.ini is properly configured.
Take a look at Windows XP - NeoSmart Technologies Wiki
 

NaYoN

New Member
#5
When I try to add my XP in Add entries, I cannot select the drive.. Is this normal?

As you can see, the drive is grayed out, and it is NOT the drive my XP is on.
 

NaYoN

New Member
#7
Ok one more, slightly unrelated question, not on easybcd but dualbooting in general, when I try to install directx on XP, I think it detects the directx on my vista and does not install anything on my XP, thus I can not run directx requiring applications. Is there a workaround for this? Also, Thanks for the help again.
 

mqudsi

Mostly Harmless
Staff member
#8
That's not possible.

Windows XP already ships with DirectX 9.0c, so you probably just don't need it updated.
 

NaYoN

New Member
#9
Unfortunately, I did a dxdiag and discovered my XP has version 9.0b... So do you have any idea how I might get around this?