Problems with Vista/XP/Ubuntu triple boot

#1
Hi all...
After using EasyBCD successfully to dual boot XP and Vista on 2 machines, I decided to try out Ubuntu 8.10 64bit outside of a virtual machine (where I normally have it).
I followed the instructions here http://neosmart.net/wiki/display/EBCD/Ubuntu to the letter.

My system is:
Dell Dimension 9150
Pentium D
4GB DDR2
XP 32bit/Vista 64bit on 2 partitions of a 500GB drive controlled by mobo SATA controller
1 TB RAID0 controlled by Highpoint 2310 card
1TB SATA drive controlled as legacy device on Highpoint 2310 card.
1TB Thecus RAID0 box on SiL3512 SATA PCI card.

I chose the 1TB dive to install Ubuntu to and used the partitioning tool to create a 100GB ext3 partition, with associated 5GB swap partition. The remaining drive was left to be reformatted as NTFS in Windows. I selected all the options as detailed in the wiki entry (inculuding the installation of GRUB to the / of the installation partition) and rebooted to Vista to Add an Entry using EasyBCD.
I selected the options as advised in this forum, i.e. to select the correct partition in the Linux tab and then select 'Not installed to bootsector'.
On reboot, what do I get?
Grub prompt.
Nothing else.
I have tried this for hours now, all with the same result. I'm a bit frustrated now and have put everything back to how it was before and wonder if anyone could offer assistance before I forget about Ubuntu for good?

<<sigh>>

Paul
 
Last edited:
#2
"We offer free support...with incredibly fast response times and super-dedicated members and NeoSmart Staff dying to help. If you've got a question, we've got all the answers."

Hmmmm
:-|

Thanks for all yr useful suggestions.


Why is it that when I add an entry to the Vista bootmangler through the program does it install ANOTHER version of grub (neogrub) to the root folder of my XP partition on the Windows system drive? The grub shell I end up has no link to the correct grub loader installed on the 2nd drive onto which I installed Ubuntu. All the files are correct and present on this drive - No fault of Ubuntu here.

The problem seems to be that, even tho' I tell EasyBCD that the correct partition to chainload to is the Ubuntu drive, it always installs neogrub to the root of the XP partition (first partition) of the XP/Vista dual boot system drive. This is the one that BIOS sees as the boot drive. I suspect I am ending up stranded in a neogrub shell with nowhere to go.

Come on now folks, help me out here...:wtf:
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#3
Thanks for being understanding that you stopped by on the weekend when we all have families and things to do as well.

Hmm :/

IT adds NeoGRUB cause the BCD can only manage things on teh MBR. If you followed the directions in the Wiki you will see that the GRUB loader was not installed to the boot drive but was directed to install on that partition or drive. Which is not the same as the boot drive used to boot vista.

NeoGRUB is then used to direct the bCD to that drive or partition to boot Linux. Which NeoGRUB then hands off the booting to GRUB.

Do you have Vista/XP dual booting correctly? Which is your boot drive? The XP Drive or the Vista drive? HAve you tried to delete NeoGRUB then add a linux entry again?

But this time remove the NeoGRUB entry. Close down and restart EasyBCD. Make sure that there is no Linux entry. From there add a linux entry. Choose GRUB, change the name if you wish. Then select the drive or partition. Then check the box for GRUB is not loaded to the MBR. Click save. Then click the Manage Bootloader and rewrite the BCD.

Close down and reopen EasyBCD to make sure the settings saved the way you want. Restart and test.
 
#4
"weekend", "families", "things to do" <<GASP>>
Jings - even the mention of this makes me sweat...

OK, thanks for the reply. I thought some controversial comment might get the ball rolling. LOL!!!

Yes, grub is installed to a non system drive as the wiki details. I followed the procedure to the letter BTW... My dual boot is good, thanks to EasyBCD and the bootmgr is on the first partition (XP). Vista is on the second partition and on a non-system drive (I have a few), I installed Ubuntu 8.10 64bit and the grub loader to the root (/).
Neogrub appeared on the root of the XP drive after adding the Linux entry but booting only left me in a grub4DOS shell.

OK - I'm going to try yr suggestions. Thanks again.

I may try editing the BCD manually, copying the linux.bin file to the boot drive and so on. This will not require another instance of grub (?)

I'll let you know how I get on...
Paul
 
#5
When you get the grub prompt type "find /boot/grub/menu.lst" note what partition and drive are identified. Reboot and when grub shows the list of boot options hit the e key, edit the boot parameters with the drive and partition noted earlier, this should allow Ubuntu to boot. Once booted run sudo gedit /boot/grub/menu.lst and change all entries to the correct drive and partition, make sure to update the default in the automagic section so it updates correctly in the future. For some reason that is unknown to me whenever I install Ubuntu the drive and partition are incorrect, the procedure above fixes the problem. I hope this helps.

Mike
 
#6
Thanks for the suggestions. I've tried editing the Vista BCD manually, copying the first 512B of the Linux installation drive to a file called linux.bin on my first active partition (XP - the one with the bootmgr file) and editing the Vista bootmanager to reflect the Linux ID. No boot - just a prompt...

I then tried another attempt at EasyBCD which installed a neogrub loader in XP (C:smile:/NST
All seems OK but just boots into a grub shell.

I'm wondering here before I try the intial suggestion of deleting neogrub and going again with grub - if I had a RAID card (Highpoint 2310) which had its ability to boot disabled through firmware: would this cause the chainloading to grub on the drive controlled in this way to fail???

Maybe this is the problem?

Paul

Addendum:

OK - reflashed the highpoint firmware and no difference. The device has the ability to boot now.

I re-installed Ubuntu 8.10 64bit and saved the menu.lst from the grub folder. I then configured neogrub by overwriting the menu.lst file in the NST folder on my first active partition. Rebooted and I get to the menu for grub on the Linux disk. However, when I select Ubuntu, I get

"Booting 'Ubuntu 8.10...
kernel /bootvmlinux...
810024 ro quiet splash

Error 17: file not found'

I forgot to save the formatted version of menu.lst, so I can't read it outside of Windows but I remember there was a UUID entry and not a root (hd2,0) entry as expected.
Obviously EasyBCD is getting me to the correct drive and grub has started...

I'm going to try dilligaf's suggestion as I have now found the grub menu...

Any ideas folks???
Paul

Addendum:

I have retried the manual bcd editing - after saving the first 512B of the Linux active partition to a file linux.bin and editing.

This gets me also to GRUB but no menu, just a "GRUB" top left of screen and a flashing cursor. No prompt.

I get the feeling there is something wrong with how my drive is identified in the Ubuntu menu.lst

@Dilligaf. The initial grub prompt, I could enter commands into. I tried yr suggestion but an error was reported. No menu, as I was still in neogrub on the first Windows partition.

I'm going to try editing the menu.lst file from the live cd tomorrow and see if grub will work.

Cheers
Paul
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#7
The Error code : 17 says there is a problem with GRUB. Not with EasyBCD or the setup. There is a actual issue with GRUB booting the Linux partition. Try reinstalling GRUB to the Linux drive and see if EasyBCD can boot it then and get past the Error 17 message.
 
#8
Hi again....

Yes yr right. I think I need to edit the menu.lst file in the grub folder as it has a non-standard description of the partition. All the examples I've seen have descriptors of the root (hd2,0). My one is missing this entry and has a UUID (?) entry with a long ID tag.
Using EasyBCD and neogrub (with the menu.lst file from the Ubuntu partition dropped in), I get to grub on the linux partition. It goes wrong, as you say, from there.
I've installed numerous times - all with the same result. Ubuntu hasn't installed grub correctly.

I'll ley you know.
Thanks again...
Paul

Addendum:

I have been at this for hours now :frowning:

I was in error when I posted that I had linked to grub on my Linux drive (and first partition). Adding in my menu.lst file to the EasyBCD neogrub entry in my XP partition NST folder just made me think I was seeing the Ubuntu grub selection choices. Not true...
I cannot make Easy BCD find the Linux grub bootsector.

I have made certain that grub is installed correctly (numerous re-installs) and have manually installed it through the Live CD. It is installed correctly on /dev/sdc1 (grub format (hd2,0)). The UUID entry that Ubuntu uses to describe the drive in the /boot/grub/menu.lst file
seems to change by one character every time I re-install however (?).
I've done this through BCD and EasyBCD and have had no success in making Ibex boot from this drive.

This is exactly the sort of thing that makes me thank Bill Gates every morning!
Probably going to give in now.

Thanks anyway...
 
Last edited:
#9
SOLUTION:

If using a 2nd hard drive and have installed grub to the Linux partition. DON'T use neogrub.
Using Add Entries, select grub - the partition required from the drop-down menu (listed as ext3) but DON'T tick the box 'Grub isn't installed to the bootsector'.

This is not made clear in the documentation.

Booting no problem now and I'm doing this from Ubuntu 8.10 with full visual effects!!!

Thanks and bb for now.

Paul
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#10
Sorry but it doesnt say anywhere on the documentation to check the box. If you look at the screenshots and read it no where does it state that you should check the box.

Ubuntu - NeoSmart Technologies Wiki

That is used as a last resort when not checking the box doesnt work.
 
#11
My mistake then! I printed off the instructions, so the screenshots were not easily visible...

Thanks for yr help on this - At least I've learned a wee bit about the boot process and grub.

EasyBCD has got me triple booting!!

YAAAAYYYY!! :grinning:

BB for now...