Quad Boot on Vista XP and 2 x OS X

#1
Hi I am struggling here

I hava A PC running Vista on a 2 drive raid 1 array (500GB SATA2)
have XP on a 3rd drive (400GB SATA2), vista gives dual boot option at startup vista or older os
also Mac OSX 10.4.10 on a 4th Hard Disk (120GB ATA) accessable via boot option at startup bios

I have just shrunk disk 3 partition (the XP drive) and succesfully install OSX 10.5 1 to an extended partition

but i cannot get it to boot!
option to boot a partition is not available in startup bios screen
and OSX 10.4.10 does not see my SATA drives larger that 128 GB



I installed easyBCD but i cant work out how to configure it to boot the relevent partition for OS X 10.5.1

added a Mac OS X addition to menu and it found mac hardisk drive 4 OS X 10.4.10 automatically but not 10.5.1 partition

any help appreciated

Roger
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Roger, welcome to NST.

I really can't help you there, the OS X boot menu it launches (darwin) should list both 10.4.10 and 10.5.1. If it doesn't that's a problem with your OS X configuration.
 
#3
Hi ok will look and see why

have 10.5.1 booting now! I installed a 5th hard disk

can boot a drive from Bios, startup boot from menu

I was hopeing i could set a boot from drive(3),Parttition(1) in the script

I might remove the 10.4.10 drive, its an old ATA 120GB and now i have 10.5.1 working on a new 250GB SATA2 Drive and it supports all my SATA2 drives and SATA2 DVD R/W Drive

Your boot util should select 10.5.1 if its the only one there
 

mqudsi

Mostly Harmless
Staff member
#4
You can do that with NeoGrub:
Code:
rootnoverify (hd2,0)
chainloader +1
boot
 
#5
Hi still cant get it to boot

Hi still cant get it to boot

tried Neogrub settings below says invalid partition repair

The Mac Partition is 'GUID' Mac Leopard 10.5.1 could that be the problem?

have removed Tiger 10.4.10 drive

XP boots, Vista Boots, But no mac unless i do it from Bios

then it boots fine

Roger

Ps: its drive 2 partition 0
but tried from drive1,0 to 5,1

You can do that with NeoGrub:
Code:
rootnoverify (hd2,0)
chainloader +1
boot
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#6
Did OS X boot before? Before you restored the Vista Bootloader? Did Darwin load at all?
 
#7
I did not know i restored the vista boot loader

Vista and XP were there from original instalation, both options at startup, xp said earlier version of windows

Both boot options worked fine

OSX 10.4.10 (On a seperate 120GB ATA drive) was booted from a bios, startup, boot from drive option!

I then added leopard 10.5.1 on a partition on the XP drive, i never managed to make that one boot, (Boot a partition is not available at startup)

I Added EasyBCD to get the Leopard 10.5.1 booting, it found Tiger 10.4.10 an added it to the startup boot options an it worked fine, a triple boot great

I now have installed a new drive 250GB SATA and install Leopard 10.5.1 on it and it boots from Boot Drive Option in Bios, works fine

But Easy BCD cannot make it work!

have now removed 120GB ATA Tiger drive, assuming EasyBCD would only boot one OSX

But still no Joy

Leopard 10.5.1 is installed ON a GUID partition, dont know if that makes a difference!

Also Vista is on a 1TB (2 drive) Raid 1 array! and Osx cannot see it! sees XP drive ok

Any ideas?

Ps sorry opened a new thread, thought old one was being ignored!
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#8
Well if you remove the Windows drive and it still wont boot that is a problem with the Darwin loader. There is nothing EasyBCD can do at that point. After you install OS X the Darwin loader should be the default boot loader and you should be able to boot right into OS X. You have to restore the Windows loader to get Windows back. So the problem is not EasyBCD. It is the OS X you are using. It is not putting the Darwin bootloader on correctly.

Mahmoud would ahve to confirm this. But that is what it sounds like to me. If that is the case we can not help. We can only help if you haev a working OS X install already on your PC.

Mac OS X - NeoSmart Technologies Wiki

Check out the Wiki for all the support we can offer.
 
#9
I did not remove the window drive i removed the other OSX drive, the one with Tiger (10.4.10) ! this drive EasyBCD worked fine and added to startup options, but i want to use the newest version of OSX!

New Leopard (10.5.1) drive, boots fine if i select boot from drive in computer Bios, New Osx is a dream to use!

But I cannot add it to boot menu using EasyBCD

Dont know if this helps but this is from Mac Info on SATA Drive OSX 10.5.1 Running

Capacity: 232.89 GB
Model: WDC WD2500JS-00NCB1
Revision: 10.02E02
Serial Number: WD-WCANK8579660
Native Command Queuing: Yes
Queue Depth: 32
Removable Media: Yes
Detachable Drive: No
BSD Name: disk2
Mac OS 9 Drivers: No
Partition Map Type: GPT (GUID Partition Table)
S.M.A.R.T. status: Verified
Volumes:
OSX1051:
Capacity: 232.57 GB
Available: 223.41 GB
Writable: Yes
File System: Journaled HFS+
BSD Name: disk2s2
Mount Point: /
Roger
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#10
It could be that Apple disabled the use of things like EasyBCD to allow them to boot up OS X 10.5. I dont know if Guru has gotten EasyBCD Leopard compatible yet.

But it still sounds as if the bootloader isnt working correctly with BCD.
 

mqudsi

Mostly Harmless
Staff member
#11
i'm working on rewriting easyBCD's mac support to fully support OS X 10.5 and its EFI capabilities. Please bear with me :smile:
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#12
So it is something Apple did with Leopard. They did change something that needs to be addressed with a update to EasyBCD. Cool. At least i was right for part of it. :wink:
 

mqudsi

Mostly Harmless
Staff member
#13
I'm not actually sure - I've had multiple reports of OS X 10.5 still working with EasyBCD; but at the same time, a lot of people cannot get it to work in circumstances where they should have been able to do so.
 
#14
I wonder if the problem is that there are new partition options in leopard

My install recommended the GUID option, this is not the default, but someone had made it work on my board so i followed his instructions!

EasyBCD says 'invalid HFS+ partition' now
 

mqudsi

Mostly Harmless
Staff member
#15
I'm researching a fix now, I don't have any other suggestion ATM. The HFS error is not a problem with EasyBC but rather with the code that Apple released (they're worse than MS when it comes to sharing!) and the way it sdetects partitions. I believe there is a possible workaround that can be implemented in EasyBCD to work around Apple's obvious (and understandable) extremely unhelpful stance on the matter.