Quad-Boot Problems

#1
Hello:

I'm a bit new to this so I hope this all makes sense (Please note: some if not all of my terminology may be off. Please correct me where necessary)

I recenty tried setting myself up with a quad-boot system using easyBCD. I already had a working Vista/Win7 dual boot and then added WinXP to the mix. This forced the system to boot into XP with no boot menu. I was able to fix this with easyBCD and get a choice of all three when I booted. Everything was great.

I next tried to add Ubuntu 9.10 (karmic). I got it installed okay and when I booted I got a GRUB menu. Choosing Vista boot loader (I think) from here took me to the Windoes Boot Menu. Everything was good, 4 bootable systems.

I then tried to add Ubuntu to the same menu as the 4 Windows choices by adding an entry in easyBCD. This DID add Ubuntu to the menu and bypassed (or removed, not sure how that works) the GRUB menu. Only problem is selecting Ubuntu doesn't boot it. I get an error of some kind saying something like "cannot boot from harddisk please inset systemdisk" or words to that effect.

My question: How can I access all four boot choices from one menu and have them all actually boot? Any help would be greatly appreciated.

Secondary question: If at some point down the road I wanted to add another Linux distro or even OSX what would be the best way to go about this?

Thanks
 
#2
Hi tw, welcome to NST.
When you installed Ubuntu, it did its default thing (since you didn't choose the "Advanced" option, and choose Grub on the Ubuntu partition), and wrote Grub to the MBR (meaning it took over the boot). Apparently, you must have also used EasyBCD=>Manage Bootloader=>Reinstall the Vista/7 Bootloader=>Write MBR to put Windows back in charge of the boot (which is fine, btw). That explains why your Grub menu disappeared after using EasyBCD to add a Ubuntu entry.

Seeing as its 9.10, you'll need to add the Ubuntu entry in EasyBCD as Type->Grub2.
 
#3
Thanks, worked like a charm!

But...now I have a new problem......

I set the grub timeout to zero and ran update-grub to give the appearance of a single boot menu. Now I boot direct to ubuntu. I can change it back to non-zero, then use the grub-menu to access the win bootloader THEN restore the MBR in easyBCD. BUT I'm then back to two boot menus.

I can change it to zero but then grub seems to "take-over" and I can't boot windows OR I can have it non-zero and restore the win loader but have 2 menus? Any solutions?
 

mqudsi

Mostly Harmless
Staff member
#4
Looks like you did not Write MBR in EasyBCD... or else the Windows BCD boot menu would have been the 1st level boot menu and GRUB would have been the 2nd... so that setting GRUB to zero timeout would not affect whether or not the choice of booting into Windows was available.