Recovering the Vista or Windows 7 Bootloader from the DVD

#1
Not a problem as such, I had to fix a pc that came up with the error boot/bcd screen on a vista install. Too late to install easybcd so I followed the steps on the neosmart webpage for the recovery. My problem was that automated repair wouldn't work and no windows installation was coming up in the window to select to repair.

So I tried the manual repair and kept getting stuck at bootrec.exe /rebuildbcd. It kept coming up with access is denied message. I tried a few times and thought that I wasn't logged in as admin and didn't have the rights to alter files, but then looking up at the top of the command prompt window told me I was logged in as admin. I couldn't work out why I was denied access, so I tried the next step which was step four nuclear holocaust. Again I got stumped by access is denied when I tried to import c:\boot\bcd.temp.

I got frustrated and was ready to wipe the disk and reinstall, when I remembered that this pc was used a lot to download bittorrents and youtube vids etc. The hard drive had a lot of use and probably had file errors on it and was heavily fragmented.

I ran chkdsk /f in the command prompt and got loads of files that were corrupt or broken or fragmented. But after doing this I suddenly could repair the vista installation with the bootrec.exe /rebuildbcd. I got the message that said ok and the system booted up fine afterward. So if you get the 'Access is denied' message, try chkdsk from the command prompt. Saved me from wiping the hd and also I couldn't perform a reinstall over the top of the existing install, since the dvd I had was pre service pack 1, and the install was at service pack 2 and would have failed if I had tried to.

Hope this helps anyone in the same position :smile:
 

JustinW

Super Moderator
Staff member
#2
Thanks for sharing your success story with everyone, and welcome to the forums.

You should run Windows' disk defrag a few times to defrag the disk.
 
#3
1st thing I did was download auslogic defrag :smile: Its way quicker than windows defrag and can optimise the disk too.

The only other problem I had with recovering apart from the access denied was following the x:\boot commands. First I thought it was the virtual drive letter that the recovery environment booted into and couldn't find bootsect, then I read more carefully and (facepalm) it was the optical drive letter (in my case e:\). If some new people to pc's don't know how to change drive letters in dos, the command is 'cd c:' or 'cd e:' in my case.

Anyway, great forum, and thanks to the website for saving me some hassle. Info was invaluable.