Recovering Windows 7 bootloader - nuclear option fails on store import

#1
I have had a dual boot machine, using grub2 to launch ubuntu and windows 7. Windows 7 has a very small boot partition, plus the large partition which contains Windows plus my data. Because of an issue with Windows Backup, I wanted to boot into safe mode, but there was no way I could insert an F8 when grub2 hands off to the Windows bootloader.
I installed EasyBCD, so as to add a Safe Mode option into the Windows boot process. Unfortunately, at this point, when I boot the computer, I receive a message "Missing operating system." I decided to rebuild the Windows boot loader. I booted from the Windows 7 installation disk, and went to the recovery console.
I tried the automated repair and it failed and threw an error "System volume on disk is corrupt. Repair action: file system repair (chkdsk)." So I ran chkdsk on both the boot and system partitions, and it reported no errors. No success with manual repair, so I moved on to the nuclear option.
I deleted the existing bcd, and created a temporary store on the boot partition. (In the recovery console, the boot partition is named C: and the system partition with Windows is named F: Although, when Windows boots, the system is on C: and boot partition is called Q:smile:
However, the nuclear process failed when I executed:
bcdedit.exe /import c:\boot\bcd.temp​
with the error "The store import has failed. The volume does not contain a recognized file system."
I'm getting messages that my system volume is not recognized, although it was working last night. What's up?
Thanks.
 

mqudsi

Mostly Harmless
Staff member
#2
Sounds like your active partition is not set or set to the wrong partition. Use diskpart from the command line to make your Windows partition the active partition and then try the instructions again.