recovery cd not fixing winload.exe

I have purchased and downloaded the vista 32 recovery cd after being unable to boot to os. After burning the cd I ran autorepair and it said it had fixed the problem! My elation was shortlived however as I restarted and it flashed Welcome to hdd in the left top corner, then showed the same black error page, windows failed to start,etc. The file that it noted was winload.exe, which I am 90% sure was not what it said before attempting to fix it. I have since tried the restore 2x and used autorepair 4x, always get that it is fixing, is successful, then returns me to failed to start,application is missing or corrupt screen upon restart. I tried chkdsk C: /r in the command and it was not recognized command, also tried to find/recover files but I only got as far as the user file I was looking for then it wouldn't open. I am looking into a antivirus bootable cd, don't know if that would help or not. I have even redownloaded and reburned cd with same result.Am I doing something wrong or any ideas on what I could try next?