RecoveryDisk doesn't work on laptop

Status
Not open for further replies.
#1
Hello everbody,

As many i also have problems with vista. Sometime ago my laptop froze while watching a movie. Nothing worked so i used the power button to restart. After restart i got the message that it could not boot vista because the registry is missing or corrupt etc.

I found the NEO vista recovery disk, downloaded the x86 version and burned the iso using ImgBurn. After rebooting with the disc i see the progress bar that windows is loading and then nothing happens. I have a black screen and i only see my mouse cursor. Not any key(combination) gives any result. The screen stays black.
To check if the cd was good i used my XP desktop and booted from the cd. Guess what, the cd works just fine. I see the menu and everthing. But my desktop does not need repairing, it's my vista laptop that needs fixing.

What is so diffent with my laptop. I have a T61 lenovo, with Vista preinstalled. Can anyone help. I am not newbie but this is too far fetched for me.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Hi wacko, welcome to the boards.
Forgive me if this insults your intelligence, but as a first-timer here, your experience level is unknown, so I'll ask anyway - have you set the laptop BIOS to boot from CD before HDD, and have you tried PF8 (or whatever your system uses) during boot to get to the "last known good configuration" , safe mode or system restore options ?
 
#3
Hi Terry. not insulted as it is true i'm new to the forum.
But yes, i changed the boot sequence and yes i tried every possibility you get after hitting F8. So safe mode or any other option gives the same result as trying to boot normally. So i really need boot recovery.
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#4
Sounds like a corrupted driver os somethign like that to me. Are you able to get into the BIOS and all that? Is it just that booting with this disc wont work? Have you tried a different disc?

Have you tried hitting F11 or F12 to boot to the Recovery partition?

Jsut somethings to try out.
 

mqudsi

Mostly Harmless
Staff member
#5
Microsoft has removed the ability to perform a repair install for Windows Vista PCs.

If System Restore from the recovery CD doesn't work, you'll have no choice but to back up your data then format & reinstall.
 
#6
Bios is working just fine. And all the standrad recovery options (F8, F11, F12 etc.) do not work.
I did not try another recovery disk, bacause i have verified that the disk itself is working just fine on other computers. Except my T61 laptop. I hoped that someone could recognize the problem and could give a possible solution besides reinstall.
 

mqudsi

Mostly Harmless
Staff member
#7
It sounds like a problem with the firmware on your laptop, especially if other boot modifier keys aren't working either.

Is there a BIOS update available for your motherboard?
 
#9
It's too bad that nobody could find me a solution. So as i ran out of options, i gave up and reinstalled vista.
This thread can be closed.
 

mqudsi

Mostly Harmless
Staff member
#10
I'm still plump out of ideas - really sorry you had to end up reinstalling...
 
Status
Not open for further replies.