Removing legacy boot files

ksalno

New Member
#1
I recently upgraded an XP machine to Win7. Upgrade was successful but everytime the PC reboots, the Windows Boot Manager comes up with 3 entries - 1) Load a previous version of Windows, 2) Load Windows 7, and 3) Load Windows XP Pro Setup. If I don't catch it quickly, it will default to Windows XP Pro Setup which I don't even have on my PC.

I installed EasyBCD and when I look at the Boot Manager entries, there are only #1 and #2 above listed. Windows 7 is shown as the default and the timeout is set at 30 seconds. However, when I use the Edit Legacy Entries tool it shows a boot.ini file that has a 5 second timeout and where Windows XP Pro Setup is the default.

Clearly, this legacy entry is over-riding the Windows 7 boot. My question is, how is the best way to get rid of this? Can I simply edit this file and delete all of the entries? Or is there a way to make the Windows 7 boot file take precedence over the XP boot file, which I assume is just left over garbage from when I did the upgrade.

I don't need to want to dual boot to XP. I simply want to run Windows 7, so I'd also be happy if there is a way to bypass this Boot Mgr process altogether. I tried the bcdedit command to turn off the bootmanagerdisplay but it didn't work, for some reason I didn't have permissions to access the file, even though I am the only user and have admin rights.

Any suggestions will be greatly appreciated.

TIA
 

mqudsi

Mostly Harmless
Staff member
#2
Hi,

Just delete entry number 1 in EasyBCD. Both entries 1 and 3 should then disappear from the menu.
 

ksalno

New Member
#3
Hmmm ... deleted entry 1 and rebooted. Entry 1 is gone but the 3rd entry for Windows XP Pro Setup is still there (now #2 on the list).
 

mqudsi

Mostly Harmless
Staff member
#4
Interesting. Can you post the contents of EasyBCD's "Detailed Mode" here?
 

ksalno

New Member
#5
Sure, here is the detail which looks ok to me.

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
path \bootmgr
description Windows Boot Manager
locale en-US
default {d340c436-0ae8-11e0-81e6-aa9478fd2cc9}
displayorder {d340c436-0ae8-11e0-81e6-aa9478fd2cc9}
timeout 30
Windows Boot Loader
-------------------
identifier {d340c436-0ae8-11e0-81e6-aa9478fd2cc9}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7 Home Premium
locale en-US
osdevice partition=C:
systemroot \Windows
resumeobject {c12eab0f-0acf-11e0-be44-806e6f6e6963}

Here's what shows up in the Legacy Editor tool, which I think is what is causing the problem. I'm just not sure how to safely get rid of this.

;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=5
default=c:\$WIN_NT$.~BT\BOOTSECT.DAT
[operating systems]
c:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Professional Setup"


I also tried to use bootrec.exe off the Win7 CD to rebuild the BCD but it didn't do any good.
 

mqudsi

Mostly Harmless
Staff member
#6
OK, it is safe to simply do Tools | Edit Legacy Entries, then select the entire contents of that file and delete. Save and exit; Reboot to test.
 

ksalno

New Member
#7
I had to change the boot.ini file attributes to uncheck Read Only but after I did that, I was able to use Notepad to edit the file and save it. Everything is working fine now, reboot doesn't even display the Boot Manager, just goes right into Win7, which is what I want.

Thanks for your help.
 

mqudsi

Mostly Harmless
Staff member
#8
Great. You're most welcome.
 
#9
Remove XP Setup From Boot Manager

OK, it is safe to simply do Tools | Edit Legacy Entries, then select the entire contents of that file and delete. Save and exit; Reboot to test.

Yes! I opened the boot.ini file in notepad, deleted all text, saved, rebooted directly into windows 7.

Finally,

Thanks!