Repair CD unable to mount/find hard drive partition

#1
Hello. First, thanks for all the great resources here and the pleasant demeanor of the forums.

My HP nx9420 is failing to boot, with a message that the registry is corrupt. I do not have a repair CD so I am trying use the one posted here. I am, however, not able to mount the Windows drive when I boot from the repair CD. I have scanned all the possible buses with mountvol but only find two mountable volumes -- one is the CD I booted from and the other is the X: drive containing files from the image. It's like there isn't a driver for my hard drive on the repair disk. Is that possible?

I'm pretty sure my drive's boot sector hasn't been messed with (first, I haven't tried messing with it and, second, I get the Start Windows Normally, Start in Safe Mode, etc. menu when I try to boot from the hard disk). And it seems like my partition is still intact since I was able to boot the Trinity Rescue Kit and get my files off with scp.

Any ideas on ways to get the repair CD to pick up my hard drive or other tools (maybe linux-based, I'm pretty comfortable there) to restore my registry?

Thanks again for all the great resources.
 
#3
Thanks for getting back to me.

Sorry if I neglected to mention it, but I did try to use Startup Repair (about 6 times). Each time it failed with a detailed error message of NoHardDrive (Problem Signature 6). There are ten of these Problem Signatures in the error message (mostly they are numbers); if getting any of the others detailed would help, let me know and I will transcribe them.

So, having tried Startup Repair and the steps above, any idea on why the repair CD is not seeing drives that TRK does?

Thanks.
 
Last edited:

JustinW

Super Moderator
Staff member
#4
If your system was working before than its probably the hard drive. You can try to get the drivers for the drive from your OEM site though and load them with the "Load Driver" button when you get the list of OSes to repair. Is your installation showing up at all in that list?
 

Terry60

Knows where his towel is.
Staff member
#5
Have you tried dis/reconnecting your HDD power and data leads a few times to clean up the pins ? A system can sometimes "die" for no more complex reason than an inability even to see it's there.