Requesting advice on dual boot windXP and then 7

#1
Hello all,

Since I am just setting up a multiboot, I was hoping for some advice. I have XP on one hard disk. I want to install windows 7 on another hard disk. If I do it using a default method, the win XP hard disk will have the boot files. What should I do either during windows 7 installation (preferably) or after such that the the second hard disk that will have windows 7 becomes the active one.? If I have this set up this way, I am assuming that then even if one disk fails the other one that has an OS will boot?

Any advice will be immensely appreciated
win2lin
 

mqudsi

Mostly Harmless
Staff member
#2
Just install Windows 7 normally wherever you want it, then use EasyBCD to change the boot drive via a single click.
 
#3
Thanks. I have installed winxp on a drive first, and then installed win7 on another drive with xp-drive disconnected so that I can boot independently in future if required. Can I install BCD on the windows7 drive in this case and add an entry for the winxp off the other drive?
thanks
 

Terry60

Knows where his towel is.
Staff member
#4
Yes, just reconnect XP, boot W7, Install EasyBCD latest build and add an XP entry to the BCD. Select "auto" and let EasyBCD do all the work.
 
#5
Thanks Computer Guru and Terry, That worked!
I plan to put fedora14 on the third drive. Whats the best way.
a) Install fedora on drive 3 while xp and win7 drive are disconnected and come back reboot to win7 and add entry to easybcd
b) install fedora on drive 3 while drive 1 and drive 2 are connected and allow grub to install in a way that it deems fit and then boot to win 7 using bios and then add easybcd entry?
 

Terry60

Knows where his towel is.
Staff member
#6
If you take option b) let Linux install with its defaults, it will take over the boot and W7 bootmgr will not be in control. Grub will give you an automatic triple boot menu. It will overwrite Windows MBR with its own and you won't have the option to use the BIOS to boot W7 from its own bootmgr
You can do a) and then add a Linux entry with EasyBCD, or you can install Linux using "advanced" options to stop it from writing to the MBR, then boot W7 and add the Linux entry.
If you do b), you'll need to boot W7 through the grub menu, and then use EasyBCD to reinstall the Vista boot loader to the MBR, then add all your BCD entries again. (or just leave grub in charge, not W7)
 
#7
Thanks Terry. If I choose to install linux on drive 3, with win7 and xp drives disconnected, fedroa 14 gives me two options to install the boot loader 1) on the MBR of the drive, or 2) first sector of the boot partition.
Will I get a grub screen in both cases, or is option 2 reserved only for facilitating multiboot from another windows drive? If I choose MBR (of the third drive), will I able to add linux entry in easybcd later when I reconnect the other drives and go to win7 through bios?

The reason I ask is because I installed fedora 14 with xp and win7 drives connected and installed bootloader on the first sector of boot partition. Upon reboot I did get the windows boot loader that I modified earlier using Easybcd. But did not get grub when I just connected the fedora drive which is not I want since I hope to make the fedora drive independent if required.
 

Terry60

Knows where his towel is.
Staff member
#8
You can safely let Linux write to the MBR of its own drive by keeping the other drives disconnected (option a, as previously discussed).
You just don't want to let it write over the other drives' MBR.
 
#10
HI, I ran into problems. I installed boot loader for fedora14 on the MBR of /dev/sda and not the boot sector of the boot partition. The xp and 7 drives were disconnected. I then reconnected the other drives and booted to win 7 and created an entry in Easy BCD as follows.
Chose Linus/BSD
Type GRUB (Legacy) : which is what I read on the inteernet
Device: Partition 1 (which seemed to correspond to the size of /boot.
Did not check the box "GRUM isn't installed to MBR/bootsector
clicked Add entry.

When I rebooted and chose the linux option, it just brought a flashing cursor on the screen.
Do I have to perform some steps inside of linux before attempting an EASY bcd addition?
Thanks
 

Terry60

Knows where his towel is.
Staff member
#11
If Linux is not on the same drive as the booted system, you need to tick the box.
btw you must be using an old build. That message text has changed in the later builds
Choose the "Linux" partition from the dropdown.
 
#12
Hi Terry,
I have downloaded Easy BCD 2.1. Beta build 141.
--------------------------------------------------------
I will show my linux devices below.
> df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/sdc8 50395844 505136 47330708 2% /
tmpfs 12104808 284 12104524 1% /dev/shm
/dev/sdc1 2015824 80952 1832472 5% /boot
/dev/sdc2 1310311052 255516 1243495536 1% /home
/dev/sdc5 100791728 32485736 63185992 34% /usr
/dev/sdc3 201585632 191888 191153744 1% /usr/local
/dev/sdc6 100791728 1320028 94351700 2% /var
--------------------------
I remember modifying fedora installation on /dev/sda8 when grub did not work on first sector of boot partition. My grub.conf file is below
> more /boot/grub/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/sda8
# initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=0
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.35.12-90.fc14.x86_64)
root (hd0,0)
kernel /vmlinuz-2.6.35.12-90.fc14.x86_64 ro root=UUID=885e95d8-1a71-4b56
-b592-c675be0fa4f9 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFO
NT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet crashkernel=512M
initrd /initramfs-2.6.35.12-90.fc14.x86_64.img
--------------------------------------

I tried two things in Easy BCD.

1. Created an entry for linux/BSD.
2. Chose Grub Legacy.
3. For Device the options under Drive 2 (drive 0 is Win7 and Drive 1 is XP) were
Partition 1 (Linux- 2GiB)
Partition 2 (Linux- 1270 GiB)
Partition 3(Linux- 195 GiB)
Partition 4 (Linux- 98 GiB)
Partition 5 (Linux- 98 GiB)
Partition 6(Linux- 73 GiB)
Partition 7 (Linux -49 GiB)

I chose partition 1. and I clicked the box "Use Easy BCD's copy of GRUB"

When I reboot, and select fedora, I get a message from Grub4dos complaining about
root(hd2,1) no such partition. and it tries to boot /boot/grub/grub.conf

If I choose partition 7 instead I get a similar message of root(hd2,7) .

everything works when I choose the fedora drive from bios, is it because it looks correctly under hd0,0, but when the win7 and xp drives are connected win7 sends it to hd2 where as grub has hd0 in it?

Checking the box of "Use Easy BCD's copy of GRUB" with the auto option just brings up a blank screen.

Where am I going wrong?
thanks for your help!
win2lin.
 

Terry60

Knows where his towel is.
Staff member
#13
grub.cfg is the grub2 equivalent of legacy grub's menu.lst.
If you have a grub.cfg, then you should be selecting grub2 from the dropdown.
 
#14
Hi Terry,
My grub directory does not have grub.cfg but has a menu.lst. Where do I go from here? :frowning: Adding a easyBCD entry from a different drive is possible right even if grub is not installed on the first sector of the boot partition?
Thanks for you patience!
 

Terry60

Knows where his towel is.
Staff member
#15
There's obviously some confusion about which partition is correct and which type of grub it uses. You say you have a menu.lst but you quote an error message that's trying to boot grub.cfg.
Have you tried specifying grub2 ?
 
#16
BCD trying hard to find hd(0,0) maybe?

Hi Terry and Computer Guru,

I tried all combinations.

1. I am installing fedora14 which has Grub(legacy) from internet searches, as shown by the presence of menu.lst
ls
device.map grub.conf menu.lst.rpmsave stage2
device.map.rpmsave grub.conf.rpmsave minix_stage1_5 ufs2_stage1_5
e2fs_stage1_5 iso9660_stage1_5 reiserfs_stage1_5 vstafs_stage1_5
fat_stage1_5 jfs_stage1_5 splash.xpm.gz xfs_stage1_5
ffs_stage1_5 menu.lst stage1

2. my grub.conf file tries to boot hd(0,0) since I installed grub on MBR of the linux drive.

3. Earlier, windows was looking in hd(2, something). So I connected the linux drive in the first port after the two dvd roms. Now in the disk management tool, the linux drive with its 7 partitions comes up as drive 0. XP is drive 1, and win7 is drive2.

4.I know based on a screen message that fedora installation was found in /dev/sda8 when I was trying to modify something.
In the drive options offered by Easy BCD, I see partition 1 which has /boot and partition 7 which has the / partition, based on sizes.

5. I created 4 entries. two were with the "use Easy BCD's copy of GRUB" checked and two were with the box unchecked. Each of the two entries had either chosen partition1 or partition 7.

If I check the box, then the error message is about grub.conf not found when I choose linux.
IF I uncheck the box, then I just get a flashing curson when I choose linux.

PLEASE HELP!! I am going crazy. Pardon me formulating a possible explanation.. but does EASYBCD have trouble finding the MBR of another drive which is hd(0.0) as it is not listed as one of the partitions ??

Addendum:

But the MBR should be on the first partition right? That did not work. Should I choose the auto option maybe?
 
Last edited: