rescue HP F11 recovery partition

#1
Hi,

i got this newer HP notebook, that has the "hp recovery partition", it has 2 500GB internal disks.

the owner has tried to recover it by himself, but failed during the process.

it has Vista x64, that looks like it is stuck during vista's setup second boot.

at boot it executes C:\Windows\System32\oobe\audit.exe - predesktop, wich says that i have to restart the installation, and gives 1 option, "OK", wich reboots the machine. If I start taskmanager and kill the audit.exe process, i get into desktop on the administrator account.

the BIOS ESC->F11 boots the C: partition(first partition), and not the recovery partition.

on the root of C: there is a "BOOTSECT.BAK" wich leads me to believe the setup process alters the MBR during setup, and because of the setup process getting fubar, it have not restored the MBR ? i dont know, just a guess.


the recovery partition is mounted as E: (FS=NTFS)
it is not hidden, and it is not active
when browsing E: with explorer, with hidden and sys files showing i have:
Code:
$RECYCLE.BIN
boot
HP
PRELOAD
RECOVERY
SOURCES
Tools
WINDOWS
hacked HP recovery folders that appears as files, and when i enter them, HP tells me not to touch the partition. it also contains the following files:
Code:
BLOCK.RIN
bootmgr
Desktop.ini
DRECOVERY
Folder.htt
MASTER.LOG <--- not a logfile, looks like it contains variables for a setup
MediaID.bin
protect.arabic->turkish
output of easyBCD deatiled debug view:
Code:
[SIZE=1] Windows Boot Manager
 --------------------
 identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
 device partition=C:
 description Windows Boot Manager
 locale en-US
 inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
 default {768789e3-35e9-11dd-b461-e92a35599e1c}
 displayorder {768789e3-35e9-11dd-b461-e92a35599e1c}
 {ba024af3-bb5c-11df-a2e4-00247e8ec8dd}
 toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
 timeout 30
 resume No
 displaybootmenu Yes
 custom:45000001 1
 Windows Boot Loader
 -------------------
 identifier {768789e3-35e9-11dd-b461-e92a35599e1c}
 device partition=C:
 path \Windows\system32\winload.exe
 description Microsoft Windows Vista
 locale en-US
 inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
 osdevice partition=C:
 systemroot \Windows
 resumeobject {768789e4-35e9-11dd-b461-e92a35599e1c}
 nx OptIn
[/SIZE]
ive tried adding a vista boot pointing to E:, wich cannot load %WINDIR%\system32\winload.exe
ive tried adding a winPE pointing to E:, but same results



so, i need some of that gurulove :smile:
i have the option to pull the drive if nescesary, and put on a windows 7, or ubuntu workstation
if u need me to provide more information, let me know, and thanks.
oh, and just to point out: i just want to gain access to the recovery partition, so i can complete a recovery. :brows:
 

Terry60

Knows where his towel is.
Staff member
#2

Terry60

Knows where his towel is.
Staff member
#4
I don't have an HP (self build), so I can only quote what they say, not my own experience.

Press the Power button to start the PC, and then press the f11 key when the standard BIOS prompts are displayed on the black screen.
 
#5
im sorry, but doesnt change anything wether i interupt the POST, and then push F11, or that i just push F11 during POST, the result is the same, it should boot from the recovery partition, but it doesnt!

why? my guess is that during the recovery process, the MBR and/or BCD gets altered, and since the recovery process FUBAR'ed, the altered MBR and/or BCD altered state remains in the current state, and i have to manually edit it back to boot from recovery partition again...

i came here cause of this site had alot of hits when searching google, and easybcd. but the hits i found concerning the HP recovery partition are unsolved, or different situation than mine.

forgot to thank you for your suggestions, terry
 
Last edited:
#7
that did it

just fire up easybcd, add entry, winPE ramdisk, path: E:\sources\boot.wim

thanks for the pointer JustinW...

now HP recovery manager is complaining, about an error 100a, just as it starts restoring factory image... but thats a whole other subject...