Revistited: No ang0 on all drives problem

#1
Hello,
First of all, thank you for a truly excellent product! I have been using EasyBCD for many years and it has always worked flawlessly. That is until the 2018-07 Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB4338822) came along. Apparently this update breaks the way EasyBCD reads the ang files on the system boot drive on my system. Let me explain:

I have a plain vanilla setup with a few boot options:

1533900990194.png
My MBR-configured disk has a small FAT (E) partition at the beginning, followed by a couple of NTFS partitions where the first one (C) is the usual boot/system partition where windows and EasyBCD reside. I am running Windows 64 bit LTSB 2016.

1533900793352.png

After the KB4338822 was installed, the system booted fine to windows, but when I tried to select any of the other boot options, I got the "no angx on all drives" error.
I am using the latest community build (2.03.207) so I tried to recreate boot files, repair, reset and reinstall and reconfigure. Nothing worked.

Eventually, I concluded that there must be some sort of problem with how EasyBCD reads the ang files on the C-drive so I copied all the ang files to the FAT drive, which is drive letter E under windows. Magically, this workaround resolved the problem!

So while my problem is solved with the workaround, I would be interesting to know why this problem appeared with the recent Windows update. And perhaps this can help someone else that my be experiencing the same problem.

cheers,

Doc
 

mqudsi

Mostly Harmless
Staff member
#2
I'm not sure, but it's possible that Windows moved things around on the hard drive. The ANG files should not be fragmented on-disk.
It's also possible that Windows compressed some of the boot files? The ANG files must not be compressed, either.