Running from C:> on Win 7

#1
Tried to run EasyBCD on a box (Dell XPS 410, 2.4 GHz dual core, 4GB mem, 250GB HD) with Win 7 RC1 that now boots to a blank screen. Tried many strategies to repair (posted issue here: http://www.sevenforums.com/general-discussion/22346-windows-7-no-go.html#post241104 ) which is how I ended up at NeoSmart.

From the System Recovery Options of the Win 7 CD I am in the cmd screen reading the EasyBCD.exe file which will not start correctly with error 0xc0000135, a .NET Framework issue.

Is there a way to start on this box from a command prompt without .NET to allow use of the tools?

Running Beta v2.0.0.63.

Regards,

Mike
 

Terry60

Knows where his towel is.
Staff member
#2
Sorry Mike, welcome to NST, but Easy need an OS with the .NET framework to run.
If you want to repair the W7 boot, use "startup repair" three times from the W7 DVD, rather than the recovery console.
 
#4
Terry60 and Computer Guru - Thanks for the information. I looked over the link re: restoring the MBR, etc. I've also run the repair function from the Win 7 install CD at least a half dozen times. The result from the first repair was a message a repair was made (and I did not write down the results as I should have). Still did not boot into windows. Went through two or three further 'repair' cycles. This time the message is the system successfully booted into the OS. Here is what happens:
The system boots up to the 'select operating system' screen with Windows 7 highlighted (it is the only OS on this box). Pressing enter produces a blank screen. A few seconds later the small blue dashes appear in the upper left hand corner of the screen for a few more seconds. Then the cursor appears in the middle of the screen. The cursor is movable with the mouse. And, there it sits.
Only one partition. I've thought about trying to partition the drive and loading Win 7 on the new partition. Haven't thought that through yet.
From the install screen of Windows 7 a command prompt is accessible from which the DIR of C: is visible.
A third party set of DOS utilities also allows for booting to a command window. From there the utilities are accessable allowing for looking around the HDD. The utilities have not made any changes.
Any further suggestions are greatly appreciated.

Addendum:

BTW, I should add that from the Win 7 install disk a bootsector repair was performed successfully. Do not believe that was the problem to begin with. That strategy did not solve the problem.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#5
Try using the recovery console to run a chkdsk /f against your W7 partition.
It sounds as though you could have bad blocks in the boot sector.
 
#6
I've run CHKDSK /f several times. Always come out clean. Tried SFC /scannnow from c:\ and c:\windows\system32. Interesting response in both instances. "There is a system repair pending which requires reboot to complete. Restart Windows and run SFC again."
Now the question is how do I initiate the repair? Rebooted four times with no change.
All the above run from a command prompt from Win 7 install.
 
#8
Thanks.

This is on the right track. The syntax doesn't quite work. I've tried a few permutations based on the information generated about the different commands for SFC.

I boot up to the screen to select the OS (Win 7 in my case), F8 to options, Repair, enter password for Admin., select command prompt from menu for the C:>. for there SFC /scannow /offbootdir=c:\/offwindir=c:\windows
This generates the screen for MS Resource Checker Version 6.0 and all the possible options for use with SFC.

Mike
 

JustinW

Super Moderator
Staff member
#9
Mike, you shouldn't need to enter a password to get to those recovery options. Sounds like you're using an installed copy on the hard drive. You sure you've booted from the recovery disc? Check your BIOS to make sure your disc drives first, and make sure to press a key to continue booting if needed.
 
#10
Was able to run SFC. Result:
"unspecified changes to system configuration might have caused the problem.
Repair Action: System files integrity check and repair
Result: failed. Error Code=0x490"

Next ran the Repair function from the DVD. This is after running the MBR suggestion yesterday. This is the result:
"Startup repair cannot repair this computer automatically. (then options to send or not send data to MS).
Problem Signatures:
Event Name: Startup repair offline
Signature 01: 6.1.7100.0
Signature 02: 6.1.7100.0
Signature 03: unknown
Signature 04: 21201225
Signature 05: external media
Signature 06: 5
Signature 07: NoBootFailure
OS Version: 6.1.7100.2.0.0.256.1
Local ID: 1033
Windows Resource Protection found corrupt files but was unable to fix some of them. See the CBS.log file"

Needless to say there is no updated CBS.log file.

c:\windows\logs\recoverydisk\ and c:\windows\logs\systemrestore - is there any help in these?

Appreciate the help.

Mike
 

JustinW

Super Moderator
Staff member
#11
SFC /scannow /offbootdir=c:\/offwindir=c:\windows
This generates the screen for MS Resource Checker Version 6.0 and all the possible options for use with SFC.

Mike
...and another problem is you didnt put a space between c:\ and /offwindir...

Sometimes all you can do is hope you got your data backed up and re-install.
 

JustinW

Super Moderator
Staff member
#13
If it said there were problems it couldn't fix its time to backup any important files using a linux live disc such as Ubuntu and re-install Windows.