Says it's bootable but can't find image on USB drive

#1
I created a system image onto an Adata 32GB USB flash drive two years ago for a new Asus notebook (model X501A) with Win 8.

I recently tried to reload the image from the flash drive, but the computer wouldn't boot off of it. (I'd made appropriate changes in the boot order in the BIOS.) Asus support believed the problem was that sometime after I had originally create the system image, I copied another file (from Word or Excel) onto that USB drive temporarily, and even though I deleted it later, this changed the USB drive from being bootable to non-bootable.

I ran EasyBCD to change my USB drive to bootable, and it said it was successful. However, when I try to boot from the flash drive, it says it can't find a system image anywhere. In my BIOS the USB drive is the first boot option and CSM is enabled. However, there's only one boot option listed for the flash drive: "UEFI: Adata USB Flash…" Somewhere online I read that you should use an entry that does not have "UEFI" in front of it, but I don't see one like that.

I'm simply trying to restore the system image from that USB drive. Any help will be appreciated! Thank you.