Second drive woes

#1
I have a system with two drives. First drive has 4 operating systems 2 windows 2 Linux. Have easy bcd 1.52 and I can boot all these just fine. I have another linux distro on the second hard drive but when I add this entry to easy bcd and save; it corrupts the other two linux entries so when I reboot and select one of them all I get is the word "Grub" at the top left of the screen. It appears when I add an operating system for the second drive it corrupts the entries for the other ones. I have to remove the linux entries and recreate the ones for the first drive again to make them work. I created the second hard drive linux entry usind hd1 partion 1 which is where I installed grub for this distro. Any ides?
 
#2
Problem resolved. It seems the grub boot loader I installed for the linux distro on disk 2 did not get setup correctly. When I tried to add it with Easy BCD it corrupted the ".mbr" file in the NST directory so that none of the Linux operating systems would boot. I reinstalled the grub boot loader to disk 2 with recovery procedure and than went back to Easy BCD to add it to the vista boot loader. Now when I reboot all selections are working.
 

mqudsi

Mostly Harmless
Staff member
#3
That's great news multiboot, I'm glad EasyBCD worked for you (not that it shouldn't or anything :wink:)

BTW, welcome to NST.
 
#4
Multiboot,

What distro of linux are you using on your 2nd drive, and would you mind posting a copy of your grub.lst for the distro on the 2nd drive? I've been trying to get the Boot Manager to boot a Fedora distro that I have on a 2nd hard drive, but haven't had any luck.
 

mqudsi

Mostly Harmless
Staff member
#5
1slyfox: I'm suspecting this is a Fedora issue. Did you try to use a VANILLA copy of GNU Grub?
 
#6
I have installed Sabayon linux ( gentto based distro ) which I am new to. I'm not sure what happened the first time the grub boot loader installed but EASYBCD was not happy when trying to add it into the Vista boot loader. You may want to start over and remove any Linux entries in Easybcd and save. Then redo them once your sure the grub boot loader on your second disk is ok. Below is the menu.lst from my disk 2.

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,0)
# kernel /kernel-genkernelreal_root=/dev/hdb5
# initrd /initramfs-genkernel
#boot=/dev/hdb1
default=0
timeout=6
splashimage=(hd1,0)/grub/splash.xpm.gz
title Sabayon Linux x86 3.2
root (hd1,0)
kernel /kernel-genkernel-x86-2.6.18-gentoo-r5 root=/dev/ram0 ramdisk=81
92 real_root=/dev/hdb5 quiet init=/linuxrc CONSOLE=/dev/tty1
initrd /initramfs-genkernel-x86-2.6.18-gentoo-r5
title Other
rootnoverify (hd0,0)
chainloader +1
 
#7
Guru,

Do you know of an easy way to install Vanilla grub (such as a iso file I can make a cd from)? I can handle that much, but when it comes to doing a recompile of things, that is still a little above my head right now.

Thanks,
Sly
 
#8
Multi,

What version of grub does Sabayon use? I know that when I boot to Fedora it reports GNU Grub version 0.97. However, like Guru said, it's probably a tweaked version of grub for Fedora and not Vanilla.

Thanks,
Sly
 

mqudsi

Mostly Harmless
Staff member
#9
The reason I'm saying this is because right here on my PC, I tried using FC6 (I use my own custom-kernel normally), and I couldn't get it to work either. I had to use grub-install from my other linux to get it working.

I'm going to add that to the documentation now, Fedora obviously taints the grub-install files, so that actually explains everything.

1slyfox: you have two options...
a) Recompile GRUB from the site
b) Install GRUB to the MBR and use GRUB to boot into either Vista or Linux...
 
#10
Guru,

I downloaded the latest version of vanilla grub last night and installed it (grub-1.95). I downloaded all of the utilities required to compile it, did the ./configure, and then "make", and then "make install", and that seemed to work. It installed itself in usr/local/bin, but I wasn't sure how to replace my current grub with the new version. Because when I go into terminal as "root" and type grub, it still shows version 0.97 not version 1.95. Sorry about being such a linux noob. Should I have just downloaded the vanilla version 0.97, because I noticed that on the gnu download site, it is the last version with ext2fs listed.
 

mqudsi

Mostly Harmless
Staff member
#11
No, you downloaded the correct version.
cd into usr/local/bin and run
Code:
./grub
notice the . in front, which means the file is in THIS directory.

If at that point it still doesn't show 1.95, run make uninstall for 1.95, download 0.97, build and run make uninstall, then re-install grub 1.95.

now running grub should run the new version.
running grub-install should install the new version.
 
#12
1slyfox,

My Sabayon Linux uses version grub 0.97. Just as a side note, I have FC6 installed on disk one of this system and had no problems installing or booting to it using easybcd to add it to vista boot loader.
 

mqudsi

Mostly Harmless
Staff member
#13
multiboot: did you add the Sabyon partition or the Fedora Partition when you booted into FC?
 
#15
Well, I looked at the limited documentation there is for Grub 2. Grub is completely different after version 1.xx. I assume everything after 1.xx is Grub 2, and the documention is currently under development for it. There is no ./grub command for version 1.95 like there is for version 0.97. Unless the code didn't complile correctly. I did install a vanilla version of 0.97, but I'm still getting grub in the left corner when I attempt to boot with the windows manager. I'm still thinking it's because XP/Vista are on my raid drive and linux is on the IDE drive. It's probably messing up the drive order somehow, but I can't figure it out.
 
#17
Guru,

I'm going to try the suggestion you made of making a /boot partition for grub on my raid drive that points to my IDE drive. I've been reluctant to do that, but hopefully everything will work out ok. When I run grub directly from a CD or Disk, it sees my raid as two separate hard drives. Fedora can see my raid drive, so running grub from a terminal inside Fedora should work. I will of course make a backup of my MBR with EasyBCD first :smile: