Second ubuntu installation.


Acer notebook with vista preinstalled, xp and ubuntu gutsy 710. Vista on C:\ , xp on E:\ and ubuntu / on extended partition logical sda6 and swap on sda7.

Everything works just fine with above setup. However,

the other night the new hardy 804 beta installed via alternate CD. Two new logical partitions created - sda8 for / and sda9 for /home. Grub was installed on /dev/sda8.

Installation completed with no problems; however, after install vista refused to boot. recovered vista bcd via vista dvd through command line.

Opened bcd in vista and added new entry Linux grub on sda8. rebooted; the boot menu displayed the second Linux, chosen this entry but grub did not come up; there were no messages.

Booted into first Linux -gutsy 710- and called gparted --> there is an entry for sda8 but there is no partition name displayed on the partition space as is for all other partitions, only for /home on sda9. Also I noticed that the 2 partition are larger with some 15% then the ones created in ubuntu partitioner.

Question please, is there a way to get the second ubuntu installed and be bootable via easyBCD? in other words have the fourth option, functional on the boot menu? if possible, how can it be edited/called differently than the third which is the standard displayed on add new entries?

thank you,

peter b

Mak 2.0

Staff member
Guru will have to take a look at that. Being that it is a Beta OS it could be something with the way the GRUB loader was installed or that is just isn't compatible with the BCD. Could be a setup change with Ubuntu in the new version that Guru has to take a look at and see if it can be added and how.


Mostly Harmless
Staff member
Welcome to NST, Peter.

It sounds to me like Hardy attempted to write to the MBR, so the procedure failed.
Did you explicitly tell it to install GRUB to /dev/sda8?
hello, nice to hear from you. yes, at install time I directed the grub to install to /dev/sda8 (the choice of NOT installing to MBR was made as ususal on all my installs).


just an afterthought, the way you speak Guru, it appears that that's what happened --> why was vista boot botched and recovery had to be used?

secondly, after booting gutsy I browsed to the new hardy / and guess what, in grub/boot/menu.lst there it was on all its glory /dev/sda7 --> now go figure peter!!

I' inclined to think that there is something out of whack in the hardy beta alternate installer. can you please approach canonical dev team and see what they say? for sure you have more leverage than I. thanks.
Last edited:


Mostly Harmless
Staff member
I can't really approach anyone until I've tested it out for myself... I'll give it a shot sometime soon and see how it goes.

Question: Why the alternate install media?
thanks for the reply; I just feel that I'm in better control of install process: I always used alternate media, maybe I'm wrong.

to be honest, I do not even know whether the live media offers the option to install grub where I want. is it possible to do that with hardy live CD beta? thanks.


and one more thing Guru, I just called

fdisk -l

in gutsy --> the sda8 appears there as bootable as well as al the other partitions including sda9
Last edited:
today I just called bcdedit.exe in vista. herebelow is the output:


Windows Boot Manager
identifier {bootmgr}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {globalsettings}
default {current}
displayorder {current}
toolsdisplayorder {memdiag}
timeout 30

Windows Boot Loader
identifier {current}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
locale en-US
inherit {bootloadersettings}
recoverysequence {572bcd55-ffa7-11d9-aae0-0007e994107d}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {54867069-73dd-11db-8a27-fcf92b9bd6e6}
nx OptIn

Real-mode Boot Sector
identifier {aa3eb1b1-8e72-11dc-8077-0016d4b463fb}
device partition=E:
path \NTLDR
description Microsoft Windows

Real-mode Boot Sector
identifier {aa3eb1b2-8e72-11dc-8077-0016d4b463fb}
device boot
path \NST\nst_grub.mbr
description NeoSmart Linux

there are 3 entries only, the fourth is shown on easyBCD after adding it. if of any help I have also output of bcdedit /enum all/ v ; I did not post it because is quite long.

it appears, reading through bcdedit help, that more uuid could be added to bcd manager.
Guru, I did a little checking here and there re what caused the problems mentioned, specifically

- why out of the blue so to speak vista boot was botched after a new ubuntu install, and
- why was second ubuntu install boot dumped to MBR and not to /dev/sda8 as directed

the first thing that crossed my mind was to check the path specified in bcdedit --> \NST folder in vista and see whether a second PBR entry for the new install was created -it was not - there was just the old one for gutsy

as you know, to generate a new ID for bcd a PBR must be created for the new install but, and here is the big but --> it can not be created because there is no such record. I just said to myself, being sure that'll be a flop, give it a try to confirm; the new PBR file was created but with 0 bytes.

now, the question is, why was second inst boot dumped unceremoniously to MBR in spite of the fact that it was specifically directed to be written to /dev/sda8 ? was it because easyBCD did not create the second PBR and place it in /NST folder? or was it because it's a problem with the ubuntu/grub install?

Guru, what's your opinion? personally I never had problems with ubuntu installs and, believe me, I did a lot of them. However, it is the first time that I used easyBCD boot mgr, why, because it's the first multiboot system that had vista preinstalled. On all my installs I used BootitNG with 100% success rate.

pls tell me what'll be the next step, it would be v nice to be able to get more boot options for linux --> it appears that bcdedit does not have a limit for the number of ID's provided that there are PBR's in place.

Best regards,
peter b


Mostly Harmless
Staff member
It seems like the MBR on your machine was corrupted, and as such you're getting weird results when EasyBCD accesses and/or modifies MBR or Bootsector-based objects.

It doesn't make sense for more than one partition to be bootable... can you paste the full fdisk output here?

Sure, here below the output of

fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x45c7f99c

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3825 30724281 7 HPFS/NTFS
/dev/sda2 3826 11481 61496820 f W95 Ext'd (LBA)
/dev/sda5 3826 6375 20482843+ 7 HPFS/NTFS
/dev/sda6 6376 8320 15623181 83 Linux
/dev/sda7 8321 8442 979933+ 82 Linux swap / Solaris
/dev/sda8 * 8443 10022 12691318+ 83 Linux
/dev/sda9 10023 11481 11719386 83 Linux

peter b
OK Guru, the problem/s that gave me so many troubles (described above) is/are solved.

Just for your info and benefit, my analysis above was proven right --> for some reason/s which is for sure not up to me to pinpoint exactly, I experienced just the outcome,

vista MBR was compromised after ubuntu install -vista rendered unbootable- and easyBCD did not create/have a PBR to create a new ID/entry into vista registry. More over, easyBCD listed the new partition sda8 in spite of the fact that there was no new PBR in place and for sure no new ID created and, when selected, a new menu item was created (based on nothing) that brought down vista boot again.

as said before, all these problems were solved manually; the steps taken herebelow:

- recreate the PBR of sda8 via ubuntu hardy alternate CD option -->repair system
- copy the PBR to a file
- copy the PBR file to the root of vista; just leave easyBCD \NST folder alone
- in vista via bcdedit command first create new ID based on the PBR file above and continue with the other bcdedit commands to create a new boot menu entry as required.
- job/repair of damages mentioned finished --> upon vista boot all 4 options/entries displayed and workable with no glitches whatsoever.

conclusion and summary --> in vista any number of boot option entries CAN BE CREATED IF and ONLY IF there is in place a PBR.

hope this helps anyone interested.

peter b