Select bcd store corrupts disk

#1
A very strange thing happened when i was tinkering with the "Select bcd store" feature.
i had "my computer" open next to EBCD while i was working with it. when i was selecting drive I: and proceeded to select its BCD file i saw the drive icons flash in My Computer, suddenly one of the disks lost its label and data used graph vista usually displays. i went o open it but it said that it needed to be formated. the weird thing is, that hard drive was never being worked on at all as its just a documents store. i have had to use recovery software to get my stuff back.

i have been very successful with EBCD, it works well for me. its just this one glitch that has troubled me. i have been working with this program for ages without problem, this is the first time something like this has happened.

when it did happen, i was switching frantically between 3 different drives CBD files. the progam kept locking up and not displaying the right info even when hitting its refreash button. i guess i finally gave itoo much to do and it destroyed a section of one of the hard drives. its just that it hurt the only drive NOT being worked on this day. frustrating!
 

mqudsi

Mostly Harmless
Staff member
#2
I had the same thing happen to me once, but I wasn't sure if it was EasyBCD or not to blame :frowning:

Are we talking about EasyBCD 2.0 beta or the stable 1.7.2 release?
 
#3
it was the stable official release.

although i cannot pinpoint exactly what action it was teh caused this, i know for certain that it was caused by a mixture of switching between different BCD stores and refreashing BCD stores. cos i saw the icons refreash themselves and lost a drive at the exact moment i was doing these actions.
 

mqudsi

Mostly Harmless
Staff member
#4
Exactly. I'm having the same issue - the refresh is by design, but somewhere along the way and very, very, very rarely the disk is being corrupted.

It happened to me when trying to make a USB bootable.

The problem is...... I don't use except for Microsoft tools and no partitioning is made. If only I could pinpoint a case so I can check if changes I make actually fix the problem or not.
 
#5
another point worth mentioning is that i may be a one off case.

this hard drive that became unusable had a tiny flaw;
it has been working fine with this little problem, but accouring to "partitioin wizard home edition" that hard drive was "unallocated" as in no paartition exists. even though i had it open and was activly using it. thats just the way its always been since i got it.

windows and the disk managment program report everything is fine though, it shows an active partition with drive letter NTFS etc etc. just the partition wizard program says otherwise.
however...
since this incident i have been able to reformat it and create a brand new empty partition and it (for the fist time in its life) acutally reports as having a partition.

so, could this little flaw have been relevant? i think yes. a strange and rare collection of odd occurances combines to desstroy my data :smile:

i hadn't considdered this until tonight, when starting this thread i was sure it was Easy BCD's fault. perhaps it was just a factor.
 

mqudsi

Mostly Harmless
Staff member
#6
It's not a one-off case - you're not the only one.

So far it was just me, then you showed up. And yesterday I had confirmation of one more case.

The problem? The corruption does not happen when doing anything dangerous!!

Dangerous: Making the USB bootable. Installing boot files. Setting up the MBR and the Bootsector.

Not Dangerous: Loading the store from modification with EasyBCD.

All I do is run "Bcdedit.exe /store ____________ ....." so if something is going wrong, it is Microsoft messing things up quite badly.

I have a solution, of course, but let me do some more research first.

Addendum:

With regards to the circumstances though: you are right. It definitely doesn't happen to a "100% perfect" USB stick - my stick too was damaged by a virus a week before. And after formatting, the problem did not reoccur.

But it is definitely bad for EasyBCD to corrupt a stick, even if all it does is just exacerbate existing problems.
 
Last edited:

JustinW

Super Moderator
Staff member
#7
For the solution could you copy the file over for modication and than copy it back to get around this issue?
 

mqudsi

Mostly Harmless
Staff member
#8
Not exactly. It's usually locked.
 

mqudsi

Mostly Harmless
Staff member
#9
Fixed in EasyBCD 2.0 Beta Build 93.

I unload the registry hive and copy to a temporary location for modification.