Server 2008:R2 Reboots just before login screen


Hello all,

I thought I would try this forum as a last resort for a small test server I have here in my office. Long story short, the Windows 2008:R2 server is the Active Directory, DHCP, and DNS server for my small office. I had been in the process of migrating from a still running Windows 2003:R2 server that had the same above roles onto the 2008 one. (The 2008:R2 server is a Dell PowerEdge with 4 SCSI drives on a PERC adapter card with two partitions, a C - 60GB and D - 144GB, just an FYI).

Yesterday I noticed that the OS had been mistakenly installed on the 144GB partition so I looked at ways to move it to the 60GB partition. I finally settled on booting to Norton Ghost 11.5 and performing an identical data duplication over to the 60GB partition. Upon rebooting, the system gave me the black screen that a bootloader couldn't be found, which I expected.

I rebooted the server to the 2008:R2 disc and loaded the PERC SCSI drivers, accessed the command console and performed the "Nuclear Holocaust" option as found on this website. I've used that before numerous times successfully for Vista and Win7 systems. Anyway I rebooted the server and it started booting to Windows 2008 making it as far as a dark screen with a white cursor that I could move. But immediately rebooted and would endlessly go through this loop until I powered down the server physically.

I am not sure why the server is not booting up properly. It seems the boot manager issue has been fixed, but maybe it hasn't? I noticed when booting to the recovery console/cd disc that it lists my 60GB (C) and 144GB (D) partitions now as G and H drives.

I also loaded regedit from the command console and loaded the System hive from the hard drive checking the HKLM\System\MountedDevices to make sure that my partitions were set to C and D partitions correctly. However this did not solve the issue either.

I am at a loss here as I had already de-commissioned the 2003 server from it's previous Active Directory role down to a member server only so I can't recover my active director database from it.

Any suggestions, advice, or help???

Do as CG says to get the boot to stop at the BSOD stop code, where you can begin to diagnose the problem, and don't worry about the disk letters. The recovery console is an OS in its own right, with its own letter map for your devices/partitions. They bear no relation to the letters that other OSs will use when they are booted. The letters do not physically exist on the devices, they are just mapped virtually inside the individual OS registries and are not therefore connected by anything other than coincidence.
(An accidental letter change doesn't cause a reboot anyway, it hangs the start at a later stage during the loading of the kernel and drivers, and in Longhorn based systems can be fixed by invoking regedit at that hang point)
Last edited:
Thanks guys for the advice! I was about ready to say there was no blue screen because when it reached the point of showing a moveable mouse cursor, everything instantly shut down with no temp blue screen. However I did that and it showed a c000000f error and requiring it to be run in Directory Services Restore Mode. So I did that and it allowed me to get into the desktop, not before giving an error that it was unable to determine file system type on volume \\?\{.... Which I think may be the flash drive connected to the server still.

Just a side note, I could not log into the active directory account, but had use the local admin account to get in so I'm not sure what is up with that at the moment but am checking it out.
In Directory Restore Mode, AD access is disabled. Glad to hear our advice worked, however.
Just wanted to post an update that the server problem has been resolved! After I was able to boot into Directory Restore Mode, and access the desktop, even that was flakey giving me errors that it could not find C:\windows, etc. Long story short I was able to access "My Computer" and discovered my system drive was labeled D:\ and my 100mb boot partition that Win7/2k8 adds was automatically discovered as C:\. I believe that is what was causing the reboots and messed up desktop environment after I was able to boot in. I did make it to regedit once more and went to MountedDevices and removed C: as the 100mb partition and pointed it correctly towards the 60gb one and immediately everything worked right away upon reboot just fine.

Personally this would have been so much easier with boot.ini to edit and be done with, but that 100mb partition really did seemingly cause most of the boot problems.

Anyway, thanks again for the help and assistance!