setting up NeoGrub

#1
I am attemting to install Ubuntu 7.10 on to my XP machine.

I followed the wiki on dual booting with vista. i thought it would work as i am using the vista bootloader.

i followed the instructions and i got the error message saying that grub could not be installed. i found that other people have got this and been told to use neogrub.

i think that i have set up neogrub wrong as when i select ubuntu from the bootloader list a heap of txt comes on the screen for a few seconds. then it stops with a error saying:

/init: /init: 157: syntax error ox(hd0,2)
[ 2.444000] kernel panic -not syncing attempt to kill init

my menue.lst is this

title Ubuntu
find --set-root /boot/vmlinuz-2.6.22-14-generic
kernel /boot/vmlinuz-2.6.22-14-generic ro root=(hd0,2)
initrd /boot/initrd.img-2.6.22-14-generic

i am not 100% that i have the partition location correct. i have 2 drives set up like:

disk A
30gb partition (C winxp)
50gb partition (ubuntu)(was vista)
240gb partition (D programs)

disk B (external sata drive conected via eSata)
320gb (my documents)

im not sure which disk is disk0 and which is disk1 as disk A is my boot disk but disk B comes up first in partition magic. also the 50gb partition is after c:/ and before d:/ but was created 3rd so i am not sure if it is partition 1 or 2. the ubuntu installer called it partition# 3

is there a way i can find out what disk is what
i have tryed having the menu.lst root line as (hd0,2) and (hd1,2) both get the same answer.

i have also tryed changing my menu.lst to this

find --set-root /boot/vmlinuz-2.6.22-14-generic
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=e888585d-ad1d-4cb1-8763-11f2a165e2c3 ro quiet splash
initrd /boot/initrd.img-2.6.22-14-generic
boot

as was sugested in this thread Vista/ubuntu dual boot problem - The NeoSmart Forums. that got the ubuntu loading screen up but it hung.

i am well experenced in xp but have only ever used linux once for a day until i got grub problems.

any help would be great.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Hi merve, welcome to NeoSmart Technologies.

Is that your UUID? Or did you get it from someone/somwhere else?

the "ro root=" line should be either a UUID, a /dev/* notation, or a LABEL prefix. I don't think it supports (hdx,y) notations.

For instance:
ro root=/dev/sdb3
ro root=LABEL=/
root=UUID=e888585d-ad1d-4cb1-8763-11f2a165e2c3

Give ro root=LABEL=/ a try.
 
#3
yes you are right that wasent my id. i realized later on that that may be the case.

after posting here i tryed reinstalling a few times. and i found out my partition location.

i also tryed just letting linux install grub properly and it did install but it dident at the some time. i.e. when i restarted grub dident show just the normal boot loader (the one i got after using easyBCD. but it did give me a menu.lst file to copy so i copyed that into my neogrub config but it still would not boot.

i will try what you sugested though.
 
#4
thankyou very much.

i swapped the (hdx,y) for /dev/sdb3 and it worked. i missread you Neogrub wiki.

i had it working but i tryed to install the drivers for my graphics card and that seemed to break it and it will no longer boot.

so i will try reinstalling it again and then get my cousin to come and teach my how to install stuff ( i know computer hardware not the programming side of things and dont get using terminal ).

thankyou again for your help.

if you happed to know of a easy way to get the drivers installed that would be great. it is an ati radion card and i have downloaded the linux drivers from the ati site and they are in my home folder.

i tryed using terminal and managed to navigate to the correct place and got into super user mode but it still said permission denied when i tryed to run the .run file.
 

mqudsi

Mostly Harmless
Staff member
#5
did you prefix the command with "sudo" like such:
Code:
sudo sh myfile.run
Oh, and you didn't misread the wiki - it's very vague on the matter :smile: