Slackware 12.0 and EasyBCD

#1
Hi there...first post.

I recently installed Slackware 11.0 on a laptop and PC, dual booting with Vista. After realising that Vista now uses the BCD method, started looking around and found this great program.... :grinning:

Now all went well on Slackware 11.o using lilo, and today I have just installed the new Slackware 12.0.......and it has all gone wrong... :x

Fired up EasyBCD and did the normal creation, but rebooted and...nothing... strange I thought, tried it again....nothing. Looked at the setup and thought I would just peel the boot sector of myself so did a dd if=/dev/sda3 of=bootsect.lnx count=1 bs=512 and copied and renamed this file over the one that EasyBCD creates...

Now, this showed an improvement getting the old L 99 99 99 99 99 99 99

I saw a new version of EasyBCD was out (1.7), so downloaded this. Was pleasantly surprised that it now shows the partitions, making it easy to select. I selected partition 2 (as it now starts counting from 0...?)

But the same, it comes up with some text at the top then says to 'enter the system disk'.

I have no problem booting of the Slackware 12.0 disk1 and selecting image/root partition, and reinstalling lilo makes no difference...

So I am at a loss. I am just downloading Slackware 11.0 again (I threw the CD's away when I decided to download 12.0 :rage:)

I am hoping to test that at least EasyBCD worked with 11.0 (like it did) then try 12.0 again.

The only thing notable from the Slackware install is that upon boot it rejects my NTFS partitions....not sure what is going on there....

Thanks in advance for any help.

Mark
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Mark, welcome to NeoSmart Technologies.

So long as the replaced bootsector gets you somewhere that means that EasyBCD is doing its job.

We've found that Lilo has some issues at times installing to the bootsector - it oversteps the bootsector boundaries making it impossible to chainload.

Bottom line: I think it's a Lilo issue caused by the particular configuration of your partitions. Try using NeoGrub instead.
 
#3
I have had manic 24hours trying to resolve this. I found out that I had a lot more corruption....not sure what happened initially..

Anyway, I ended up repartitioning and starting again with Vista and Slackware. Same problem, even using V11.0

Tried peeling the bootsector off again, and using BCDEDIT to add the entry and the same result... L99 99 99 etc..

Tried neogrub and it reports cannot mount drive...

:ldown:
 

mqudsi

Mostly Harmless
Staff member
#4
Sounds like you've got some serious data corruption and possibly a damaged MBR :/

The best thing to do is to clear the MBR of all bootloader data:
Code:
dd if=/dev/zero of=/dev/hda bs=512 count=1
Note that this will clear all data on the hard drive hda. Make a backup of valuable data first!

Simply re-partitioning won't fix the MBR if it's been corrupted.
 
#5
ahhhh, can I run something past you?

I just cleared the MBR as above, and just went to recreate my partitions and notice that it states that my (RAID) disk is 250mb when it's not.....its the size of one of my disks....

Now, when I installed Slackware the other night before I went to sleep, all was OK, but I wonder if it all went pear shaped as it has not correctly detected my RAID array?

Addendum:

Frankly what is confusing me now, is how the hell I got Linux installed in the first place (and EasyBCD working) when none of the kernels pick up my NForce4 raid controller...
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
I really don't know - I don't have a RAID setup myself, so I'm not really an expert on that subject (soon, I hope :tongueout:).

Only thing I can think of is that Linux isn't installing to the RAID config but to the actual (single) drive, bypassing the entire RAID layer? I honestly don't know, but that seems like the most likely thing if you're seeing 250MB as the size when that's actually the size of only a single disk.

I had no idea you were running a RAID, I'd have suggested you double-check or re-create the RAID before resetting the MBR.....
 
#7
I've tried a few things now to try and get the partitions set up. I usually use Partitionmagic under BartPE, but that failed as well...

So I had to install Vista, just to use its partitioning. Then I can restore my ghost backup....

I think I can safely say that it got screwed by the fact that the install was assuming one 250gb disk ( I am surprised it booted after this point at all TBH ) ...

The trouble is I just cannot fathom how I got it installed in the first place ....
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#8
I don't think the install is "assuming" it's on 250GB disk, rather I think that's what the RAID was showing it...
 
#9
Yeah, true. Next step is to try and see what Slackware image works (if any)......

Thanks for your help btw. I know it has gone outside the realms of EasyBCD now!
 

mqudsi

Mostly Harmless
Staff member
#10
No, that's plenty OK :smile:
these forums aren't just for EasyBCD, they're for anything that might cross your mind :wink:
 
#11
OK, I got Gentoo and Ubuntu. Ubuntu did not seem to pick it up, but Gentoo did using dmraid, by invoking the dodmraid ('do' dmraid)
There is a how to on the gentoo wiki, which is mostly handraulic, and ideally I want to try and find out how to use dmraid with Slackware....

At this point I still do not know if lilo or grub will work in the same way.....but it is a learning process I guess.
 

mqudsi

Mostly Harmless
Staff member
#12
That's good news - good luck getting it to work on Slackware :smile:

Did you ever find out how it was that you had it working with Slackware 11?
 
#13
A miracle I think....

I was going away so I just did an install, booted, it worked, so thought :grinning: and did not boot it again. Looking at the 11.0 install it was just using the sata.i image which would not have detected my array either, so I have no idea how I managed to escape toasting my array on that occasion. Maybe it coincided with a full backup, and format of my 'data' partition, and I restored OK. A bit of a coincidence though (and very lucky).....shame I deleted a part of my backup when I was away, as did not have enough disk space >.<