slax in a folder

manan

New Member
#1
is it possible to add slax which is in a folder namely E:\slax to the boot menu?

slax has the option of being directly started from a hdd - a portable os in a sense
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
Not that i know of. The only reason i say this is because the BCD doesnt allow for a path like that to a boot loader. The XP one doesnt allow for it either. If it is a Portable OS in a sense they have to offer some kind of booting solution for it.
 

mqudsi

Mostly Harmless
Staff member
#3
I'm not sure - it sounds like something that should work, provided you have enough info....

Slax would need to have a bootloader stuck in the \slax\ folder, and you could *theoretically* convince the BCD to boot from it - but I'd need more info on what file and how it works before that would be possible.

Any instructions on their site or documentation?
A screenshot of the contents of the Slax folder would go a long way, too.
 

mqudsi

Mostly Harmless
Staff member
#5
Look around in the boot folder - do you have a menu.lst, grub.conf, menu.conf, grub.lst or something like that in there? Perhaps in a subfolder called GRUB?

Post it's contents here. Please use a
Code:
 box :)
 

mqudsi

Mostly Harmless
Staff member
#7
OK, look for a file called vmlinuz* (where * is anything) or initrd*

Give me a screenshot of the folder with those files.
 

manan

New Member
#8
both these are in the boot folder that is d:\slax\boot\

list of files
Code:
isolinux.bi_
isolinux.bin
isolinux.boot
splash.cfg
vmlinuz
memtest
splash.lss
splash.txt
splash2.txt
initrd.zip
also a folder named DOS
 

mqudsi

Mostly Harmless
Staff member
#9
Well, I don't know if it'll work, but try this:

Add a NeoGrub entry and stick this in the configuration file:
Code:
find --set-root /slax/boot/vmlinuz
kernel /slax/boot/vmlinuz ro root=/dev/*****
initrd /slax/boot/initrd.zip
boot
Replace the ***** with the appropriate Linux drive name (e.g. hda1 or something)

No guarantees this will work, of course.
 

manan

New Member
#10
i tired it and this is what im getting:
Code:
VFS: Cannot open root device "hda5" or unknown-block(0,0)
Please append correct "root"= boot option
Kernel panic-not syncing: VFS: unable to mount root from unknown block (0,0)
 

mqudsi

Mostly Harmless
Staff member
#11
Well, sounds like your "root=" section is incorrect.

I have no idea what it should point to, the best place to ask would be in the Slax forums (if there are any). If it were a standard Linux setup this would be far easier, but I'm utterly perplexed as to what hd** value you would give for a FOLDER in a drive....... :S

If you point any Slax expert to this thread, they should quickly be able to see what EasyBCD is trying to do and give you the right info for the "kernel....." line.

Good luck with that, and please post back if/when you get that figured out.
 

manan

New Member
#12
ok i will post it on slax also but a little R&D atleast got me to load the drive on which slax is it gave me a VFS: drive loaded as read only (which is the case when u load slax from a folder) but the error changed:
Code:
Warning: Unable to open an initial console
Kernel Panic: - not syncing:No init found Try passing init= option to kernel
 

mqudsi

Mostly Harmless
Staff member
#13
It means that initrd.zip isn't what you need.... What files are in the zip folder?
 

mqudsi

Mostly Harmless
Staff member
#15
No, that's of no use to me.

Why don't you just ask them??

Addendum:

Also, renaming a file from .zip to .gz doesn't actually make it so.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#17
well, that explains it... :lol:

menu.lst is going to look for a initrd.gz - and it doesn't exist.
Convert the zip file to a gz file, then try to boot.
 

manan

New Member
#18
sir ur understanding ... in the slax folder there is a .gz file the first code u gave had .zip as the extension which i blindly copied upon digging into the slax folder i found that the extension for the initrd file gz and then i changed the exension in the menu.lst file from zip (which does not exist) to .gz :wink:
 

mqudsi

Mostly Harmless
Staff member
#19
Ah, I understand you now :smile:

Sorry about that then :wink: