SSD cloning, recovery partitions and Asus computers

#1
Hey guys. I've been stumbling on this issue for quite a while now. Nothing seems to improve the situation.

The story in a nutshell:
1. I bought an ASUS G51Jx-A1 laptop. It has a 500 GB drive and a Win 7 x64 Home premium OS.
2. I bought a Crucial M225 SSD drive, 120 GB. I want to move the recovery partition from the old drive to the new one, then reinstall Win 7 in the rest of the space.

3. I used Acronis true image to clone the old drive to the new one, but when i ran recovery (pressing F9), it just stuck...didn't want to work....and then returned an error message with "cannot connect do a device on your computer". Windows sometimes froze during startup.

Does anyone know how to make the ASUS recovery part on the SSD to start and install?
I have the manufact. recovery dvds and a windows installation + recovery disk.
I tried to use the manuf. recovery dvds, but they are aimed just at restoring the hidden partition. I tried that and it didn't boot at all from that one.
I tried fiddling with bootrec, diskpart and others, but nothing seems to work....and I'm going in blind here. Did anyone try this or knows what the problems may be?

Many thanks for your time,
G.