"Startup Repair" Tool Doesn't Startup or repair

#1
Hi all:

I searched this forum, Windows, Acer's and no answers so let's see if anyone out there has this answer. I have an Acer laptop 5920. It started getting glitchy after Mozilla Firefox updated two weeks ago. I went to an older restore point and rejected the updates and all was well until yesterday. Got a message my computer didn't start properly and found the startup repair tool running. It ran for hours. I removed the battery, gave the laptop a 20 second rest & plugged it in. Restarted and got to a blank screen. Tried again pressed F2 this time and tried to see if any solutions existed there. Nothing except I was able to enable D2D boot and move up the USB boot option. Tried again with F12. My choices were to start normally or to use Startup repair. Gave Startup repair another twirl. After three hours, went to hit cancel and was told all the "repairs" would be lost, so I gave in and let the laptop try to repair itself overnight. 12 hours later, Startup repair was still running.

I do NOT have a VISTA emergency boot disk. I did back up my whole system to an external hard drive a few days ago when the laptop started getting glitchy and did a separate back up of photos and music and documents. Even with the USB D2D boot enabled, I couldn't use the external hard drive's files to do so. I would like to download an emergency boot disk file to a USB but can't find how to do that on my son's desktop with XP. I also have downloaded Acer's eRecovery zip file but can't unzip it on his XP powered desktop to burn a CD.

I'm in the middle of writing a book and I'm on deadline. Is there a way to fix this or should I just go for Windows 7 and start from scratch again?

Thanks all