Still can't boot UBUNTU

I have a sw testing PC with 6 O/S's and they all boot except the last one, ubuntu. I think I've tried every combination and permutation of "adding" a new booting O/S entry but I still wind up in the "grub-prompt" shell after choosing the ubuntu boot choice. I think there should be an entry like this: U:\ubuntu\winboot\wubildr.mbr "ubuntu" in some file somewhere in EasyBCD as I saw this line of code elsewhere. At one time, ubuntu did boot (but with that config I couldn't get Win7 x64 and/or Win 2000 Pro to boot).

I've tried all of the forum tricks as well as "BCD deployment" "write MBR ....," and so on, to no avail. I've set the drive as G:, where ubuntu appears as the actual boot device, etc...., and I've tried "grub2" and "wubi" -- still nothing. When I choose "grub2" or "wubi" I have no control over choosing the drive (in "add new entry") as EasyBCD automatically sets up the "boot process (??)."

There is a way I can actually boot into ubuntu, but my client will not like it (it's complicated and won't boot Win 2000 Pro nor Win7 x64 as I stated above); plus, I recently upgraded this ubuntu to 11.4 "wacky or wooly (?) narwhal" with no problems.

What I am trying to do is to use my BIOS boot drive which comes up in Win7 with ubuntu and the other 4 O/S's all of which boot (just the ubuntu won't go).

This forum entry is my last ditch attemp before I quit EasyBCD 2.1 (I wanted to stick with it) altogether and go to another booter pgm which I've used in the past and found to always work (but is not as nice-looking as EasyBCD).

Boy, I surely hope you can help! I am not a wise guy, but am ready for an onslaught of suggestions I've probably already tried. I really hope there's something I am missing in my ignorance. Thank you greatly in advance.


Mostly Harmless
Staff member
I'm assuming all other 3 entries work fine via EasyBCD?

And are you adding Ubuntu or Wubi?


Mostly Harmless
Staff member
What happens when you add a Wubi entry and change nothing with EasyBCD 2.1?
Hi. So as not to shotgun an answer to just setting up Wubi with no embellishments, I re-did it a minute ago and still came up with the grub> shell prompt at which I then I type in: reboot

Please keep tryining. Thanks.


Mostly Harmless
Staff member
Do you know where the Wubi bootloader files are stored on your PC?
G:\ubuntu\winboot\ -and- somewhere, in another EasyBCD installation, I actually saw this line of code: G:\ubuntu\winboot\wubildr.mbr "ubuntu" -but- for that particular BIOS boot drive (using <F8> on this mobo -- on most mobos it's <F11>) the ubuntu drive is actually U: (because as you pointed out that the drives change in My Computer according to which BIOS boot drive or EasyBCD drive one boots to/from).

Also, I should point out that if I <F8> to another BIOS boot drive, namely, my WD WDC1500, then a whole other EasyBCD install shows up in which ubuntu actually works (boots) very well but Win7 -and- Win2000 Pro won't boot -- point is, I had 2 choices as this: A) boot into Win7 and forfeit ubuntu; -or- B) boot into WD WDC1500 and forfeit Win7 and Win2000 Pro; so, I chose the latter and will fight it out with the ubuntu problem.

Again, in the choice B), above, is where I saw that line of code (using drive U:) and where ubuntu boots well.

That's about it, except that I have rebooted my PC 100 times (I boot into an SSD for the Win7 choice A)), and I found that iReboot doesn't seem to correspond with the EasyBCD GUI changes, so I reboot using a gadget (just figured I'd inform you about that minor thing).

Thanks greatly so far.


Mostly Harmless
Staff member
What are the contents of ubuntu\winboot on your PC?
Mahmoud, is everything all right? You're still on my side, helping, right?
Thanks, again, in advance.


Mostly Harmless
Staff member

Do you know why you have a wubildr(2).cfg file?