stop: c0000221 unknown hard error

#1
I have one Win7 drive and one XP drive and I was able to dual-boot for a long time. But yesterday I got this error saying \systemroot\system32\ntdll.dll wit the stop blue screen.

What procedure do I use to recover my dual-boot?

Thanks,
Robert Wycoff


Addendum:


Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {e8190d4c-dc32-11de-80b8-864a340c6335}
resumeobject {e8190d48-dc32-11de-80b8-864a340c6335}
displayorder {e8190d4c-dc32-11de-80b8-864a340c6335}
{e8190d49-dc32-11de-80b8-864a340c6335}
{e8190d4a-dc32-11de-80b8-864a340c6335}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 30
Real-mode Boot Sector
---------------------
identifier {e8190d4c-dc32-11de-80b8-864a340c6335}
device partition=C:
path \NTLDR
description Windows XP - Endeavour - HDP725050GLA46
Windows Boot Loader
-------------------
identifier {e8190d49-dc32-11de-80b8-864a340c6335}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7 - Endeavour - STM3320620AS
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {e8190d4a-dc32-11de-80b8-864a340c6335}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {e8190d48-dc32-11de-80b8-864a340c6335}
nx OptIn
Windows Boot Loader
-------------------
identifier {e8190d4a-dc32-11de-80b8-864a340c6335}
device ramdisk=[C:]\Recovery\e8190d4a-dc32-11de-80b8-864a340c6335\Winre.wim,{e8190d4b-dc32-11de-80b8-864a340c6335}
path \windows\system32\winload.exe
description Windows Recovery Environment
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice ramdisk=[C:]\Recovery\e8190d4a-dc32-11de-80b8-864a340c6335\Winre.wim,{e8190d4b-dc32-11de-80b8-864a340c6335}
systemroot \windows
nx OptIn
winpe Yes
custom:46000010 Yes
 
Last edited by a moderator:

Terry60

Knows where his towel is.
Staff member
#2
Have you tried F8 immediately after selecting XP to access the NTLDR extended boot menu. Then try "last known good ....." or safe mode and system restore back to before the problem.
(Have you just installed new hardware or software ?)
 
#3
I got lucky. I ran chkdsk and then copied ntdll.dll from dllcache to system32 and both systems booted without problems.

Thanks for your help,
Robert Wycoff