Strange .NET issues in Vista SP1

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#1
So i installed Vista SP1 yesterday. All is fine and dandy. Got some bootloader issues which stump me. Like the fact that i have to use EasyBCD is XP to manipulate teh boot laoder....but anyways not why i started this thread here.

I am trying to install .NET 3.0 and up on my Vista machine. But everytime i try i get this error.



So i go into the cntrol panel. I get the Turn Windows features on or off and i see this:



It seems to me that .NET is fully activated. SO why cant i install .NET 3 or 3.5 or even the SP for them? If i try to install Visual Studio 2008 i get errors related to .NET and it is bugging me.
 

JustinW

Super Moderator
Staff member
#2
You know Mak, there was a recent thread somewhere (I think you replied in it) with the same issue. Try 3.5 instead and see if that works. .net 3.5 is working fine on both of my Vista machines and it was applied after upgrading to SP1. If it doesn't work... well I installed mine with the installation of Visual Studio. You could always go get the express version and hope it installs it for you. Not a great solution, but it works :smile:
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#3
Sorry i already said this.

SO why cant i install .NET 3 or 3.5 or even the SP for them?
I tried the stand alone. I tried the quick and the full versions that they had. Neither of them install. I get the same errors no matter which i use. Which is why i am prompted to ask. CAuse i cant use the stand alone installer to install. Which is where my problem varies from that thread you mention. I did say to use the stand alone. But sadly it dont work for me. :wink:

My install came with SP1 already slipstreamed in. It was a ISO i downloaded right from MSDN. I never had to install Vista RTM then update to SP1. IT was Vista SP1 upon install. So either these things are already applied or they changed something when slip streaming SP1 into Vista and that is what is causing me grief.
 

JustinW

Super Moderator
Staff member
#4
Oh sorry.. missed that last bit about VS issues. If .net 3.0 is supposedly already enabled, have you tried applications that rely on it to work?
 

mqudsi

Mostly Harmless
Staff member
#5
.NET 3.0 ships with Windows Vista. .NET 3.5 ships with Windows Vista SP1; so you cannot install either manually.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#6
Well that answers that question. What about .NET 3.0 SP1. Is that already included? I woudl think so since .NET 3.5 is already included. So that means basically i have to install .NET 2.0 and earlier.
 

JustinW

Super Moderator
Staff member
#7
3.5 is compatiable with all earlier releases. Applications designed in 3.5 can work on computers that have earlier versions or applications deisgned under 2.0 or earlier well work with the newer versions. So there is no need to go installing every version of the framework.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#8
I figured out at least part of my problem. I had to reinstall 1 app that needed .NET 2.0 since i had most of the files saved from before but not all of them. So that is sovled. Just have to try VS 08 again now.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#10
Yeah i get the same error as the other thread when i try to install it. That .NET 3.5 fails even though it is supposed to be there. Meh i will figure it out at some point. VS 08 isnt mandatory for me at this time.