Strange Problem EasyBCD/Windows 7 RE


I had a Samsung EVO SSD die. I had an Acronis image backup. I also had an old system dual booted from an HDD and Windows 10 dual booted.
I restored acronis to a new SSD including the signature but it would not boot. Either it hung in the Bios initialization or says winload.exe not found when I changed to IDE. I used the HDD system with EasyBcd to reload the bootmgr from EasyBcd but nothing helped. I then downloaded and used Windows RE in desperation. It said it fixed the problem but it had not. Winload still not found. Waste of $19.75
Finally after 7 hours of restoring, trying things etc, I used EasyBcd and reset it completely. Then added the 3 systems back. That worked. Wishing had thought of that up front. Something went wrong with the disk identification number in the BCD after the swap out and RE did not fix it!!!
All it took was EasyBcd to recreate everything. I am out $19.75
The BIOS initialization hang was fixed by going to IDE from AHCI. Why that changed is beyond me, but the SSD hangs on AHCI now and works on IDE.
Very strange.