Struggling with a triple-boot-system, please help...

#1
Hi,
I have installed a fresh triple-boot system. Installation sequence XP>W7>Xubuntu...
Until W7 everthing was OK; Bootloader works and can be edited with easyBCD....

My plan was not to run into GRUB. So I was selecting the key setting during Xubuntu install and avoided GRUB writing into MBR. After editing easyBCD I can select in the Windows Bootloader XP, W7 or Xubuntu, OK.
But when I select Xubuntu, it goes to GRUB and orces me to select again. This I want to avoid....

Any advise?

Regards, hl
 

Terry60

Knows where his towel is.
Staff member
#2
You successfully boot Linux, but are getting an unwanted second boot menu ?
If so, what you need to do is edit the grub menu to change timeout to 0.
You cannot edit grub.cfg directly (well you can, but you shouldn't! It's not persistent), but grub2 allows users overrides via another file.
see
Grub 2 Basics
 
#3
Hi,
the situation changed slightly, but the problem remains.....
I searched the internet and found the below information:
Ubuntu

So, I decided to re-install...
Following situation: 2 HDD, on HDD 1: XP und W7 installed, easybcd on top, everthing is fine, on HDD 2 Xubuntu-partition (and swap), during installation the option "device for bootloader install" selected. To avoid that GRUB takes over MBR, it was installed into the SAME partition, where Xubuntu is in.....

Installation went thru, no problems at all, I can maintain the third OS in easybcs, can select Xubuntu, but it does not show up.....
My feeling is, the link between the easybcd entry and the Xubuntu-Partition is not there...

What do I need to maintain (details please) in easybcd?
in BCD deployment, must I select "write inot MBR"?

Support is appreciated...
Regards, hl
 

Terry60

Knows where his towel is.
Staff member
#4
Don't touch BCD deployment or any of the advanced options.
You just need "Add new entry", nothing else.
If you've used any other options to modify something, delete the Linux entry (Edit Boot menu) and add it again (Add New Entry).
Select grub2 in the dropdown menu and let EasyBCD auto-configure.
You shouldn't need to do anything else.
 
#5
Hi,
I have been there already...It was my first try.
It ends up in a dos-like screen (terminal) with the title

GRUB4DOS 0.4.5b

then some info, ends up with the prompt

grub>


What is expected here?
hl
 
#7
Hi all,
I had to re-install Xubuntu again > issue is back. no with easybcd 2.2 .....

hdd 1: xp & w7
easybcd 2.2, two entries > ok

then hdd2: xubuntu 13.10
added entry in easybcd

when xubuntu selected it goes to grub prompt (message : minimal bash lke editing......

Any idea?

hl