Succeeded.. Finally..

#1
Let me first state that I'm completely new to multi booting. But I had some time to spare and was interested in multi booting into Windows 7, Mac OS-X Leopard en Ubuntu 9.10.
In short: it took me about 12 hours to get it working.

The first problem I ran into was a partitioning problem. GPT and MBR were not synchronised. But I never new they could co-exist on the same drive!

I tried:
1. Install Windows 7 with partitioning with the Windows 7 installer: working
1a. Install Mac OS-X on second partition: working
1b. Install EasyBCD v1.7.2: working
1c. Install Ubuntu: Needed to make partition with Gparted. Destroyed MBR.
1d. Repairing Windows 7 MBR: working. But Mac OS-X - and Ubuntu partition destroyed
1e. Gave up on this approach

2. Install Ubuntu 9.10 with partitioning with Gparted on 3rd partition: working
2a. Install Windows 7 on 1st partition: working
2b. Install EasyBCD v1.7.2: installed but Unbuntu was not booting. Ended in Grub
2c. Gave up on this approach

3. Install Mac OS-X with partitioning with Disk Utility on 2nd partition: working
3a. Install Windows 7 on 1st partition: working
3b. Install EasyBCD v1.7.2: working
3c. Install Ubuntu on 3rd partition: working
3d. Repair Windows 7 MBR: working. Mac OS-X still booting. Ubuntu not booting.

This was the second time that Ubuntu was not booting. It had to be a problem with EasyBCD. I found out that Ubuntu v9.10 was using GRUB2 instead of GRUB. And EasyBCD v1.7.2 could not handle GRUB2. Tried several workarounds with editing the config file. Still no luck. Then I found out that the EasyBCD 2.0 beta will work with GRUB2.
And guess what? It works!

It's now a matter of tweaking the setup of all OS's.. Sigh...
 

mqudsi

Mostly Harmless
Staff member
#2
Thanks for sharing your feedback, nobodie. We're working on making everything a true one-click experience with EasyBCD 2.0.... and we're almost there. Just some major changes/overhauls to the OS X support and we'll be done :smile:
 
#3
You guys are doing a heck of a job Computer Guru!
I just got through using EasyBCD for the first time and it has to be the easiest thing I have ever used, and it worked!
pg
 

mqudsi

Mostly Harmless
Staff member
#4
Thanks, pg... that's very kind of you and much appreciated :smile:
 
#5
I installed 10.5.7 using Chameleon 2.0 on a 2nd partition, works well, recoginzes linuz9.10 amd vista. Hover when booting through vista easybcd ubuntu works, 10.5.7 will not load. When I use the darwin bootloader to install 10.5.7 i am able to use easybcd to select both imac and linux. It would seem that Easybcd 2.0 does not work with the Chameleon bootloader. Is thee a work around?