SuSe 10.1 Boot Problem


First off let me say thanks for 1.51, solved (one of) my problem(s) with dual boot vista/suse 10.1. But sadly that led to an other problem. You see now i get to the grub boot screen and all seems fine but when I start suse I get an "kernel panic - not syncing: I/O error reading the memory image" error.

So I looked around and found this thread witch seemed to suggest that I should edit my .config file to match my root partition. The problem was I didn't know witch .config file to edit so I edited all I could find searching in knopix (probably not a good idea). But that didn't work so know I'm here begging for help.

Oh and a few other things in EasyBCD 1.51 my setting are HD 0 Partition 3 but in knopix my suse root drive shows as hda5 and the line before "kernel panic" is something like "attempt to access beyond end of device hda3: rw=16"

I hope thats enough info and that somebody *hint*Computer Guru*hint* can help.
/regards Kim
Hey Kim, welcome to NeoSmart Technologies.

Would you happen to have /boot/ on a separate partition? Or is it one partition for Linux (SWAP and Storage aside)?

If that's the case, try to point EasyBCD to the /boot/ drive.

But if you're partition for Suse is hda5 then you should have put Hard Drive 0 Partition 5 - not 3......

Thanks for the fast reply.
No the /boot/ (folder at least) is on the same drive/partition as the rest (/root/, /usr/ etc) and that is hda5 in knopix. I tried switching the disk/partition to 0/5 in EaasyBCD but that only resulted in a boot error (in the vista boot loader) when trying start linux.
/Regards Kim

Edit: And yes I only made three partitions for linux main, SWAP and Storage
How did you change the partition/drive?

In order to successfully change the info you must delete the old entry, and then create a new one from the Add/Remove Entries page...
That is what I did. I'm thinking that is some .config file that points to the wrong drive/partition, but I don't know witch and I could be wrong.

Thanks for your effort
Give this a try:

Add/Remove Entries -> NeoGrub -> Install NeoGrub
Tools -> Restart Computer

Select NeoGrub from the Vista boot menu. What do you see?
I feel almost guilty posting this but no that didn't work. The only thing that happened when I tried to boot the neogrub was that it showed a black screen for a second, it then went back to the default vista boot loader and loaded vista.
Probably not, is there a log somewhere? The screen going black where more like a flicker to fast to make anything out, and then it loads vista without me doing anything. The thing is the suse safe mode works so I'm thinking it has something to do with suse not with EasyBCD. Thanks for your time and help but maybe I should except it as a lost cause and reinstall suse.
I didn't know it would boot in Safe Mode - now that you mention it though, it changes things.

In that context, this probably means that your kernel was somehow corrupted. You need to either recover or reinstall SUSE - sorry.
The memory file that the kernel panic is talking about is the vmlinuz line in the grub file.

Good luck!

When re-installing SUSE make doubly sure that you don't install GRUB to the *MBR* but rather to the *Bootsector* then re-run the Linux-creation steps in EasyBCD :smile: