Suse 10.2, blank screen with neogrub...

#1
I am trying to create an XP, Vista, Suse Triple boot.

First I've tried to use nst loader but all I had is a GRUB_ at the top of the screen.
(I cannot install GRUB to the boot sector during Suse installation because of system restart like someone else already wrote before. So I've installed to the MBR and later I restored it.) I tried evrything to make it wotk ;(

So I decided to use neogrub. I've installed and modified the menu.lst based on my working floppy suse, grub start disk.

like this

title Suse
root (hd1,1)
kernel /boot/vmlinuz-2.6.18.8-0.1-default root=/dev/hdd2 vga=0x31a resume=/dev/hdd1 splash=silent showopts

initrd /boot/initrd-2.6.18.8-0.1-default

Saidly all I have is a blank screen if I select the neogrub menu...


XP On primary master, first partition
Suse Secondary slave
Vista on Sata
 

mqudsi

Mostly Harmless
Staff member
#2
Hi SmallDot, long time no see!

What's the filesystem on your Linux drive? Is it ext3fs?

Anyway, I recommend you install a vanilla version of GRUB2 from the grub website to the bootsector of the linux drive and then configure EasyBCD to chainload it according to the EBCD docs @ http://neosmart.net/wiki/display/EBCD/Linux

NeoGrub is very tempramental! :wink:
 
#3
Hi there

I am a bit confused with the file system. (0x83)
if I check with df -T it sais ext3
if I type root(hd1,1) in grub than it sais ext2fs,
I hope you can figure out the truth :smile:

Can you past a link about how to get (and how to install) grub2 (I am just learning linux)

With chainloading I am stacked.
I cannot put grub to Bootsector during installation of suse because of system restart.
If I install it later root (hd1,1),setup (hd1,1) and chainload it with easyBCD all I have the GRUB_. (if I select drive=0, partition=2 because somehow my hd1 is drive 0 in Vista) I've also tried dd ... bs=512 etc with the same result.

By the way grub-install hd(x,y) which is in the doc link,is not working for me. Is it a Grub2 feature?
 

mqudsi

Mostly Harmless
Staff member
#4
#5
From your previous link

su -
grub-install hd(x,y)
init 6

grub-install hd(1,1) in may case
generates the error some problem with '(' (I am far from home for a few thay, when I am back I will past the exact error.)
Actually I don't see syntax like that in the link...
 
#6
The exact error is ..
smalldot@linux-g36z:~> su -
Jelszó:
linux-g36z:~ # grub-install hd(1,1)
-bash: syntax error near unexpected token `('


Where can I find grub2? (on http://www.gnu.org I found some alpha release but I dont know which one is good for me, and how to install it)
 

mqudsi

Mostly Harmless
Staff member
#7
that's really weird! It's a GRUB error, but that's standard grub prompt.

try
Code:
grub-install hdxy
instead?
 
#8
grub-install hd1,1 is working ...

Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script `grub-install'.

(fd0) /dev/fd0
(hd2) /dev/sda
(hd1) /dev/hdd
(hd0) /dev/hda

but after recreating the easyBCD entry still just GRUB at the corner ...
 

mqudsi

Mostly Harmless
Staff member
#9
where did you tell Easybcd you installed grub to?
 
#10
Under vista Hard drive = 0, Partition = 2
Under XP Hard drive = 2, Partition = 2
(I get the hard disk numbers from Disk Manager)

The generated file is the same in both case (Attachement) which seems to be good or at least it has something to do with GRUB. :smile:

This method shoud work if the stage2 is on a different hard disk (secondary slave)??
 

Attachments

mqudsi

Mostly Harmless
Staff member
#11
That may have something to do with it.
Can you try to put Stage2 on the same drive and partition? I don't see why they shouldn't be...
Put GRUB on the bootsector of your partition with the /boot folder.
That partition should have stage2 and stage1.5 anyway...
 
#12
I just backuped evrythink, created a new ext3 partition on my boot drive (after resizing the others) installed grub there and evrything works perfectly.

I think GRUB boot partition should be on the boot drive....
 

mqudsi

Mostly Harmless
Staff member
#13
that's interesting...
GRUB is working now via EasyBCD from the Windows Vista bootloader?
 

mqudsi

Mostly Harmless
Staff member
#15
Well, that's good news.

You've really worked hard to get this working, I'm sorry it was something that simple. I should probably add it to the documentation - this DOES only happen with Fedora though, so it's interesting.

Anyway, I'm happy it's working for you now :smile: