System restore giving corrupt prompt


Active Member
Got a vista premium computer thats acting up, my father tried shutting off his antivirus through msconfig because of a password issue, rebooted and now hes getting a black screen after the windows splash screen. So I thought maybe the registry corrupted. We rebooted with the built in Vista recovery cd maker, 1st cd in, and it takes him into system restore, tried five system restore points, each resulted in an error. Something being corrupt basically.

We tried changing everything back in the msconfig. Didnt make a difference. Wont boot.

From safe mode, Went into command prompt, did a "help" and tried bcdedit, but everything we tried wasnt an internal or external command. In other words it wasnt there.
There wasnt a fixboot or fixmbr choice for him in that help list. I can navigate the C:\ drive where his windows is installed (See all the folders). He does have a D:\Recovery partition made by Vista.
He doesnt have a copy of the vista recovery cd you guys provide to try yet. Nor a full recovery cd with an image to put it back to factory install. Is this most likely a registry issue ? I have to send him your recovery cd in the mail. But just wanted to see if the problem could be narrowed to a certain place in the boot process.
Thanks for your help again :smile:
Last edited:
Justin posted a link earlier today.
I can't remember which thread, but I saved the link in my clipboard manager gadget because I thought it might be useful in future.
I didn't expect it to be so soon.
Yeah I posted it yesterday [post=35350]here[/post], see if that helps.


Vista threads shouldn't go in the legacy support category btw...
Last edited:
ok I'll try that a little later, Has anyone ever ran into a issue where system restore from safe mode deletes an onboard nic driver ? I can now boot into normal windows vista, but son of a gun, the onboard driver is now missing. Should I run system restore a few more times to see if system restore re-adds it, or is there another way to get it back. I verified in device manager the driver under "Network Adapters" is no longer there. Its a PCI Realtek RTL8201N 10/100mbps onboard nic. Not getting a internet connection in the browser nor is it pinging in command prompt.
I give up

Welp whatever system restore did it screwed up my services.
Vista firewall wont even turn on, dhcp client wont turn on, no internet connection
did a netsh winsock reset , not recognized, guess im doing a full reinstall. Did I ever mention I hate vista.